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TaxAct Professional Support Options

Support Hours:

Monday – Friday
8:00 a.m. – 5:00 p.m. 

Saturday & Sunday
Closed

All times are in Central 
time zone

Check our support page 
for in-season hours

Sales hours:
Monday – Friday
8:00 a.m. – 5:00 p.m.

Online Support Center
For the fastest answers, search our online 
Help Topics.   

Account & Software Questions:

        professional@taxactservice.com

        (319) 731-2682 option 1

Tax Questions:  

        protaxhelp@taxact.com

        (319) 731-2682 option 2

Order, Payment & Sales Questions:

        www.taxact.com/professional

        prosales@taxact.com

        (319) 536-3571

https://www.taxact.com/professional/support
https://www.taxact.com/support/category/300145/helpful-tax-topics-taxact-professional
mailto:professional%40taxactservice.com%20%20?subject=
mailto:protaxhelp%40taxact.com%20?subject=
https://www.taxact.com/professional/
mailto:prosales%40taxact.com%20?subject=
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To submit an idea to our product development team:
1.   Click Online in the top menu

2.   Click Submit Product Suggestion

3.   You will be directed to our TaxAct Product Suggestion 
      page, where you can describe your idea

To provide general feedback:
1.   Click Online in the top menu

2.   Click Submit Product Feedback

3.   You will be directed to our Feedback page, where you  
      can rate your user experience

We continually incorporate your suggestions into TaxAct 
Professional Editions to help you provide the best possible 
service to your clients.

Have a suggestion  
to improve TaxAct  

Professional Editions? 
We want to hear from you!
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Download & Install

TaxAct has simplified the Professional Editions installation process for 2024. You can now 
click one link and install all desired products at the same time.

Enterprise Editions files can be shared on a network, either your own local server or on-
line to TaxAct’s secure servers.

Be sure to verify the system requirements before installing the software.

Recommended Method:

Download the TaxAct Professional Installer: TaxActProfessionalSetup.exe (3.08 MB)

Alternative Method: Download Installation File from Practice Manager

Go to www.taxact.com/professional 
and click the Sign In button in the  
upper right corner.

1

Sign in with your Username and Password.2

Click the Orders & Downloads tile.3

5

https://www.taxact.com/professional/system-requirements
https://tax-prd-desktop-downloads-s3.s3.amazonaws.com/phishbait/TaxActProfessionalSetup.exe
http://www.taxact.com/professional/
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Click the Download link to the right of the product you wish to download, or to download 
multiple products at once click the Download our simplified installer link at the top. 

Note: During our preview season the link on the right may say Preview instead of Download.

If the installation does not automatically run, locate and double click the File icon 
to manually install the software.

(Type CTRL+J in Firefox or Chrome to help you locate your downloaded file.)

4

5

Install Your Software Using Simplified Installer (Recommended)

Open the downloaded program 
file. On the initial screen, click 
Next to begin the installation.

Select the checkbox next to  
“I Accept the License Agreement”, 
then click Next.

1 2
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Select the year to install.

Selected products still in 
development will be listed. You 
will be notified when they become 
available.

Choose the products to install. 
Click the arrow to expand more 
options.

TaxAct will install all selected 
products and notify when installa-
tion is complete.

3

5

4

6
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Share Files on a Network (Enterprise Editions Only)

Online Network Option

Local Network Option

The first time you launch the program, you’ll be prompted to set up your practice. At this 
point, you need to choose whether to save shared files on your local network, or on Tax-
Act’s secure servers.

This is recommended if your practice has multiple preparers or if you want access to 
returns from multiple locations. See our Online Networking FAQ for more information.

If you choose “Locally on my computer,” your client returns will be saved to a location 
of your choice on a local drive or server. If you wish to share this data with multiple 
computers, this folder should be in a shared network location. See our Local Networking 
FAQ for more information.

Whether storing data online or locally, all users of the software are required to sign in with 
their TaxAct username and password upon software startup in order to authenticate the 
account. Each user will need to sign in again after either 30 minutes of inactivity or after 
24 hours (whichever is sooner).

Have questions about how to set up a local network? Refer to the Microsoft and TaxAct 
Support resources below:

Select the radio button next to the  
option you prefer. If you are a 
returning user, we’ll remind you 
which option you used last year.

Click Continue.

Windows Support support.microsoft.com/en-us/products/windows

TaxAct Support – Network Installations taxact.com/support/22832/

TaxAct Professional Support taxactprofessional.com/support

1

2

https://www.taxact.com/support/22880/
https://www.taxact.com/support/22878/
https://www.taxact.com/support/22878/
https://support.microsoft.com/en-us/products/windows
https://taxact.com/support/22832/
https://www.taxact.com/professional/support
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Install State Editions

Adding or Removing States from a Return

Open a return, then click  
Return > State > InstallState.

Select each state you wish  
to install or Select All.

Click Auto Install to add  
the state modules with  
recommended settings.

Or, click Manual Install to add states to an 
alternative location or to a network.

1.    Once a state has been installed, open the return you wish to add the state to and click 
       Return > State > Add/Remove State to attach or remove the state from a return. 
       Or from the left navigation panel select Add / Remove States

1

2

3
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Installation FAQs

I downloaded the program file but can’t find it on my computer. How do I find it?

Try any of the following:

•    Repeat the download process,

•    Use keyboard shortcut CTRL+J in your web browser, or

•    Find the Downloads menu item or icon on your Web browser.

You can also use Windows search to locate the installation file on your computer. The 
TaxAct Professional Installer file name is TaxActProfessionalSetup.exe.

Why am I getting an error when clicking on the installation file?

A temporary or partial file may have been created during the download process due to 
connection issues. This is usually designated with something added to the filename, such 
as “_part.”

To avoid this problem, check your browser for progress messages, set your browser to 
run downloads directly, or use a different browser.

What are TaxAct’s system 
requirements?

Please refer to the minimum 
and recommended system 
requirements for TaxAct 
Professional below. For the 
best performance, especially 
for users with large client 
lists or very complex returns, 
we suggest exceeding the 
recommended system 
requirements where possible.

While TaxAct Professional may run on systems not meeting these standards, system 
performance will be sub-optimal.

10

http://windows.microsoft.com/en-us/windows7/searching-in-windows-frequently-asked-questions
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Import Master Information

You can save time by utilizing TaxAct’s Import Prior Year Online Master Information 
feature. Practice, Preparer, Client, and General information will be automatically 
populated based on last year’s entries. When you sign into the program for the first time, 
you will be prompted to import Master Information.

TaxAct will search your local computer for master information files and bring them in 
once you authorize the import. If no files are found, you will see the following screen:

If you stored Master Information online last year, click the I used TaxAct’s secure 
servers last year button.
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Set Up the Software

The first time you launch the software, the TaxAct Setup Wizard will walk you through 
steps to set up Master Information, including Practice, Preparers, Client Status, 
Directories, and General categories. For best results, complete every tab in the setup 
window before clicking the OK button. To access each section individually after the initial 
setup, click Preparer > Master Information

Master Information is stored on TaxAct’s Secure Servers, which allows for:

•    increased security

•    more powerful practice management

•    set return-level permissions and assign returns

•    see practice invitation status at a glance

•    activate or inactivate preparers

Practice

You can edit and access your Practice, 
Preparer, Client, and Return information 
through a secure online account 
anywhere, anytime. You’ll need to sign in 
to Practice Manager each time you open 
the TaxAct software, so please ensure 
you have a stable Internet connection 
before proceeding.

Enter your practice information as you want it to appear on tax returns, labels, letters, and 
other correspondence. The information you enter can also be linked to each preparer (see 
the Preparers Information menu section below). When finished entering your data, click 
Continue to Preparer Information.

12
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Preparers

Preparers Information menu

After completing the Practice 
information, the next step is to enter 
information for each Preparer in your 
practice. You must enter at least one 
preparer in order to continue the setup 
process. To access the full Preparers 
menu, click Add New Preparer.

Note: The first preparer you add should be 
yourself.

Click Add New Preparer to enter information, keeping the following in mind:

•  Note: The first preparer you add should be yourself or the default preparer.

•  Check the Use My Practice Information box (in the Address section) to link the 
    preparer to the Practice address. Otherwise, enter the preparer’s specific contact 
    information.

•  In the Basic Information section, selecting the “IRS may discuss…” option will populate 
    the Third Party Designee field on the return with “PREPARER.”

•  Enter “None” if the IRS has not yet issued a CAF number (you must submit Form 2848, 
    Power of Attorney and Declaration of Representative to the IRS to receive a CAF 
    number).

•  Be sure to enter a valid email address for each preparer. This is necessary in order to 
    invite preparers to your online network.

To change the default preparer, select a name from the Default Preparer dropdown menu 
in the Preparers tab (Preparer > Master Information > Preparers). If you delete the 
Default and close the window, the next preparer in the list will become the Default.

Each practice is assigned a unique alphanumeric identification code called a “Practice 
ID”. If you have multiple preparers in your practice, each preparer will have the same 
Practice ID. The Practice ID, EFIN and PTIN (or SSN) is synched with your TaxAct Account to 
streamline the e-file process.
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To locate your Practice 
ID, sign in to your TaxAct 
Account and look in the 
upper right corner.

Use the Invite Status 
column to manage 
preparer invitations.

Electronic Filing Info Menu – E-Filing Info

An Electronic Filing Identification Number (EFIN) is required to e-file returns. To obtain 
an EFIN, please see the IRS page Become an Authorized e-file Provider for more 
information.

To use your preparer information to receive e-file notifications, the check the box next to 
Use preparer information for E-file notifications. Please make sure if you have checked 
the box that you have entered your contact information on the Preparer Info screen, or 
an alert will appear. Both a mobile phone number and an e-mail address are required to 
receive notifications.

IRS EFIN Requirements for Tax Professionals & Software Companies

The IRS requires tax software companies to collect and verify EFIN Tracking Numbers from 
its professional customers. Your Tracking Number appears on the IRS e-Services Summary 
in your IRS e- Services account.

https://www.irs.gov/e-file-providers/become-an-authorized-e-file-provider
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Please submit a copy of that IRS e-file application summary (including Tracking Number) to 
TaxAct for verification. Having your EFIN verified prior to the start of tax season will help avoid 
disruption to your e-filing services. All EFINs will need to be verified prior to e-filing.

Generally, professionals who have been verified in a previous year will not need to be 
re-verified; however, TaxAct may request that you re-verify in order to e-file. You can 
check your EFIN verification status in your TaxAct Account. If your EFIN is rejected for any 
reason, we will notify you via email.

To submit your IRS e-file application summary or to check the status of your EFIN Verification:

1.  Sign in to your TaxAct Account.

2.  Click the Practice Administration Tile.

3.  Click EFIN Verification to expand.

4.  Enter your EFIN and the Tracking Number found at the bottom of your IRS e-file Application 
     Summary. Reminder: To obtain a copy, sign in to your IRS e-Services Account.

5.  Click Choose File to locate and attach your IRS e-file Application Summary. 
     (PDF is preferred, but .jpg, .bmp and .png files are also accepted.)

6.  Check the box to indicate you are authorized to submit this information. Click Submit.

7.  We will notify you via email if your EFIN information is rejected for any reason, and 
     your verification status will be available in your TaxAct Account within 2 business days.

Electronic Filing Info tab – Credit Card

Credit card information is only required if you choose to pay e-file fees with each 
submission (Pay Per Return method). If no credit card information is entered, you will be 
prompted for credit card and billing information each time you e-file. Credit cards may be 
used to purchase E-Signatures as well.

If your TaxAct order includes unlimited e-filing or you have prepaid for e-filing, you do not 
need to enter credit card information. Simply enter your EFIN, then click OK.

Tip: Double check that you’ve entered your credit card information correctly so that your e-files 
are not rejected due to insufficient prepaid funds.

https://www.taxact.com/support/22327/
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Permissions Menu

Practice Administrator - The first preparer you add to your practice will be the Practice 
Administrator by default (this cannot be removed).

Data Management Tool: The Data Management Tool allows users to permanently 
delete Client Data for all years. Only the Practice Owner can manage this permission. 
Permissions are divided into 3 categories: Client Manager, Practice and Preparer 
Information, and Client and Return Information.

Practice and Preparer Information

•  Edit Practice Information – Allows user to update the Master Information for the practice
•  Edit Preparer Information – Allows user to update the Preparer Information for any 
    preparers within the practice
•  Edit Client Status Options – Allows user to edit existing status, add new status, or 
    delete status for Client Return Status and Client Pay Status
•  Change General Filing Settings – Allows user to change Filing and Printing options 
    from the General Master Information tab
•  Change Miscellaneous Settings – Allows user to change Miscellaneous options from 
    the General Master Information tab
•  Change Calculation Settings – Allows user to change Calculation options from the 
    General Master Information tab
•  Edit Master Forms – Allows user to change Master Forms information, including Charge 
    by Form, Billing Invoice, Instruction Letter, and Schedule K-1 Letter (in application 
    product versions)

The Practice Administrator permission can 
be given to other preparers in the practice 
by checking the box for “User is Practice 
Administrator” on the permissions tab in 
their preparer information.

Anyone with the Practice Administrator 

permission will be able to:

•  Invite other preparers to join the practice

•  Modify other preparer’s permissions

•  Deactivate (or reactivate) preparers
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Client and Return Information 

•  Create New Returns – User can create new clientreturns
•  Open Returns – User can open client returns they are authorized to view
•  Remove Returns – User can delete client returns that they are authorized to view 
•  Import Returns – User can import client returns from PDFs or prior year TaxAct data
•  Export Client Information – User can export client information in a customized or 
    comprehensive comma separated (.csv) or tab delimited (.txt) file
•  Print Returns – User can print client returns, organizers, consent forms, labels, and 
    reports
•  E-file/Online Backup Returns – User can e-file client returns or back up returns online 
    (Enterprise Local storage users only)

Invite Menu

To grant network access to other preparers in your practice, the practice owner must 
“Invite” them to join your practice via email (instructions below).

The email will include a unique link the preparer must click in order to create his or her 
own TaxAct Account so that the account will use your PracticeID.

Note: If you are the practice owner, you do not need to invite yourself (you are automatically 
added to your practice’s network).

Your invited Preparers will have access to the following areas of Practice Manager (listed 
by tile name) in their TaxAct Account:

• Orders & Downloads
• Professional Reports
• Practice Administration (EFIN Verification only)
• Client Xchange (if purchased by the Practice)
• Resources
• My Info
• My Preferences

Your invited preparers will not have access to the following tiles in Practice Manager:
• Preparer Invitation
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To invite preparers:

Once all information in the 
Preparer Information setup is 
complete, click Finish.

Click the Practice  
Administration tile

Click Preparer Invitation.

Complete and click the  
Send Email Invitation 
button.

1

2

3

Client Status Menu

Click Add New Status to create a custom message to appear in the Return 
Status and Payment Status columns of Client Manager.

18
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Directories Menu

The Directories menu displays where client documents are stored and 
allows you to change those locations.

General  Menu

The General menu presents 
options for filing/printing, 
calculation, and miscellaneous 
preferences.
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Set Master Forms Defaults

Once you make all of your Master Info selections, the Setup Wizard prompts you to set 
defaults for various forms you use in your practice.

To complete the Master Forms setup:

Once you complete the setup for each form, a green checkmark will appear on the tile so 
you can easily see which you have not yet completed.

You can return to this section anytime, but keep in mind that setting Master Forms 
defaults from the beginning will save you time later.

Click the appropriate program tile.

More options appear on the 
screen, which could include:

•  Charge By Form

•  Billing Invoice

•  Instruction Letter

•  Schedule K-1 Letter (applicable 
    product versions only)

1

2
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Charge by Form

This feature allows you to 
set default billing rates by 
form. You can add forms 
and charges not listed 
on the blank lines at the 
bottom of the list. Use the 
Select Type dropdown 
menu to switch between 
federal and state forms.

Master Billing Invoice

This is where you can:

•  Assign custom invoices

•  Select the Charge by 
    Form method or list a flat 
    preparation fee

•  Charge a separate 
    electronic filing fee

•  Create custom fees

•  List separate charges for 
    preparation of Federal 
    and State returns

•  Apply a local sales tax 
    amount
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Master Instruction Letter

From here, you can set preferences for the formatting and content of your filing 
instruction letters, including:

• Letterhead

• Date parameters

• How to refer to your practice (e.g., “me” or “us”)

• Whether to include your name in the signature area

To access Master Form Data, click Preparer > Master Information > Master Form Data.

Copy Master Information to Client Returns

TaxAct allows you to apply Master Information changes to an individual return or to all 
returns. You can choose to select by form type or by clients.

Click Preparer > Master Information > Copy Master Form Data to Clients(s). Click 
Copy Master Form Data to apply changes. Changes to Master Information can be applied 
to select returns or all existing returns.



23

Set Up the Software

TaxAct now includes the ability to convert previous year 1040 ProSeries, TaxSlayer Pro™, 
and Taxwise® client data. Other software programs below can use PDF import:

•  CrossLink®    •  Intuit Lacerte®  •  Drake®

•  Intuit ProConnect Online® •  ATX™   •  UltraTax®

Convert Client Data

To add a new client to convert:

Click Client Manager > Add Client > Convert Clients to TaxAct Professional
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To import a client to convert:

Click File > Import > Convert Clients to TaxAct Professional

When asked: “Would you like to convert your 1040 clients’ data from your previous year’s 
software to TaxAct Professional?” chose Yes.
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Next, select the ProSeries software you used the previous year and click Next.

Be sure to save or back up all your client data, and to remove any locks or password 
protection from your client files before continuing.
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Browse to the client data you wish to convert.

Select the client data you wish to convert and click Next.

The client data will then be converted to TaxAct Professional files. This may take a few 
minutes depending on internet speed and the number of files to convert.
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After the client data has been converted, the files will be added to Client Manager. Please 
see Data Conversion Frequently Asked Questions for any further questions.

https://www.taxact.com/support/25906/
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Integrated eSignatures

TaxAct now offers Integrated eSignatures, backed by DocuSign®, making it easier for you 
and your clients to get the signatures you need to e-file. Integrated eSignatures are only 
available for 1040 returns, state supported signature forms, and on applications for bank 
products. Files must be a PDF or JPEG, with a 25MB per envelope size limit.

Select which documents you would like to eSign, and click Continue.

Request new eSignatures

To request a new eSignature you can do so 
in the filing steps or the eSignature tab:
Find Request eSignatures on the E-File 
Summary Steps, and click Start.
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If you do a custom eSignature request, simply click the Send Custom button on the 
eSignature tab.

To customize your request, add Sender and Recipient details, and set reminders and 
expirations. After you have customized your request, click Continue to Payment. 

Note: If you are sending a custom request, you are required to add a new eSignature.

If you have a current balance, check I Accept to use your available balance.
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If there is no available balance, click Use Credit Card. Choose Use Saved Credit Card 
to use an existing credit card, or New Card to enter a new or different card. After your 
payment information has been entered, click Continue.

Confirm your charges and payment method, and click Review Envelope.
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Review your request. TaxAct supplies you with a default Subject Line and Message, but 
if you would like to customize either, uncheck Use Default Subject and/or Use Default 
Message to enter your own.

After you have reviewed your message and included documents, click Continue to send 
your request.
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Add new eSignatures

To add a new eSignature:

Click Upload to launch dialog window, and click Add Signature.

Click the Add Signature drop-down menu, then click the Signature rectangle and drag it 
to the desired location. After you have placed your signature, click Save and Close.
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Click the dotted menu and then Edit Signatures to return to the menu.

eSignature Dashboard

The eSignature Dashboard is where you will be able to view, track, manage, and edit your 
eSignature documents.

33
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To view the Options menu for your documents, click the dotted menu next to the entry 
you wish to access.

To customize your request, click Edit Request to bring up the Editing Request screen. 
Here, you will be able to edit your request email by clicking on the Edit Email tab, or set 
reminders and expirations under the Customize Request tab.
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To send a reminder email to your recipient, click Send Reminder.

To view your entry’s previous statuses in the History Log, click View History.

To download forms that have been sent for that entry, click Download Forms, select the 
document you would like to download, and click Download.
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Custom 
eSignature 
Requests

To create a custom 
eSignature request, 
click send custom 
eSignature request

To void your entry, click Void Request. Enter a reason for voiding the request if you wish, 
and click Void.

36
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Next, select the documents you 
want for the eSignature Request 
by clicking Browse to select

If you select a PDF file, you will then be automatically prompted to add a signature to your 
document. If you later want to add or edit this signature, click the three-dot menu next to 
“Requesting signature” at the top of your page and then click “Add signatures”
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To add a taxpayer signature to the document, 
click “Add Signature” and then “Taxpayer Signature” 
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Fill out sender and recipient information and select an expiration date.
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Confirm your envelope balance and proceed with payment.

For further information
Please see the following links:

•  Integrated eSignatures

•  eSignatures Frequently Asked Questions

40

https://www.taxact.com/professional/efiling/esignature
https://www.taxact.com/support/25907
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Import Last Year’s Client Returns

TaxAct Professional Editions include the ability to import information from last year’s 
returns into the current year’s program.

You can import:  •  Prior year returns created with TaxAct
    •  PDFs from other supported tax preparation software.

Import TaxAct Returns

1.  Click File > Import > TaxAct 2023 Client Return(s).

2.  Click Select All to import all returns in the directory, then click Import.

You will receive a message when the import process is complete. The return(s) will be 
added to the Client Manager with a status of “Imported.”

41
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Add/Edit Client Returns

You can add, edit, and delete client records in the Client Manager, which displays all 
current client information and the status of each return.

To access Client Manager after the initial setup process, click Preparer > Client Manager.

From within a return, click the Clients button.

Import TaxAct Returns

The information fields in Client Manager will populate as you add returns.

To open a return, double click the desired client record. To add or edit a client’s 
information or return, click the client name in Client Manager. Once the record is selected, 
you can find additional menu items in two ways:

1.  Return Menu: Open, Copy, Check Out, 
     Check In, Lock, Unlock, Remove
2.  Edit Menu: Information, Notes, Return 
     Status, Billing Info, Assign Preparer
3.  E-File Menu: Return, Extension, 
     Amended Return

4.  Print
5.  Update Fed EF Status
6.  Custom eSignature Request
7.  Collect Payment
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Add a Client (and associated return)

Edit Existing Client Return

Click the Add a Client button. If you didn’t complete the Master 
Forms section of the setup process, you may be prompted to do 
so. Fill out all Master Forms prior to adding clients.

Select Add New 2024 Client to complete the new client contact and 
basic information portion of the return, then click OK.

 a.  Click Client and fill out the basic information for the client.

 b.  Click Preparer to assign a preparer, set the Return Status 
        and Payment Status, and make any related notes.

 c.  Click OK to save the client record and create a new return.
      (Turn on auto-save if prompted).

Click the client record in Client Manager.

Double click the client record. The return opens in Forms Explorer, where you may 
edit or review forms directly. To switch to the Q&A interview method, click the Q&A 
button in the toolbar near the top of the page.

1

1

2

2
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E-file Client Return(s)

E-file Center

When you’re ready to e-file a client return, 
we recommend using the E-file Center, 
where you can submit single or multiple 
returns.

From here, you can also view e-filing 
information for other preparers in your 
practice and navigate to e-file and refund 
status reports.

To access the E-file Center, you must be in 
a client’s return. Click on the E-file button 
in the navigation menu.

E-file a single return

From the E-file Center, click the 
first link, Submit Electronic Filing 
Return. This will open to a screen 
in the Q&A.

Select E-File and click Continue.

When e-filing your first 2024 
return: If you have not entered 
your Practice ID, EFIN or PTIN (or 
SSN) in Preparer Info, you will be 
prompted to confirm or enter the 
missing information. You will also 
need to have your EFIN verified, 
and confirm that you are the 
responsible party for verifying 
your EFIN, before you can proceed 
through the e-filing steps.

1

2

3

https://www.taxact.com/support/20662/
https://www.taxact.com/professional/efiling/efin-ptin
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If you’ve enrolled in Protection Plus Audit Assistance, you will also indicate 
whether you want to purchase Protection Plus for your client and complete the 
subsequent entry screens.

A screen titled E-Filing Summary will appear, where you can navigate to specific 
e-file topics (see list below). You can return to this screen at any time by clicking 
“Back” or continuing through all the screens for a topic.

The list of topics is client-specific and depends on the details of that client’s return, such as 
whether there is a refund or liability. Topics include:

•  IRS E-file Authorization: Self-Select PIN – In this required step, choose Self-Select PIN 
   or Practitioner PIN via Form 8879, then enter related information.

•  IRS Refund Method: Direct Deposit – If client is receiving a refund, you must choose 
    bank products, direct deposit or check, then enter the required information for the 
    refund method. If client owes money to the IRS or state, you must choose how they will 
    pay – direct withdrawal, credit card (pay now or pay later), or paper check.

•  Driver’s License Information (optional) - Enter or confirm drivers license information.

•  In Care of Information (optional) – Enter In Care Of information here.

•  E-File Alerts – These alerts must be fixed for a valid e-file as required by the IRS.

•  Print Returns and E-File Documents (optional) – From here, you can print your client’s 
    federal and/or state return and filing instructions. You can also print state forms from 
    here, including Form 8453 and other e-file signature documents.

•  E-File Notifications (optional)  
    – Sign up for E-File Notifications.

•  Request E-Signature – Request an 
    E-Signature. For more information 
    see Electronic Tax Signing.

4

5
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https://www.taxact.com/professional/resources/protectionplus
https://www.irs.gov/forms-pubs/about-form-8879
https://www.taxact.com/professional/efiling/esignature
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After completing the E-Filing Summary, complete the screens to “sign” your client’s 
return. (Information required for signature depends on whether Self-Select PIN or 
Practitioner PIN was chosen.)

Then begin TaxAct Alerts, which checks the return for potential errors, omissions 
and tax-saving opportunities. Make any necessary changes to the return.

If your client’s return has any associated fees, the E-filing – Payment Method screen 
will appear. You must select whether to pay the client’s fees from your prepaid 
account (see instructions below) or by credit card. Note: if you purchased a bundle 
that includes unlimited e-filing, you will not be prompted for payment.

Continue through the next screens to submit the e-file.

To set up a prepaid account, you must enter the information in Preparer Master 
Information. (Click Preparer in the main menu, select Master Information, then 
Preparers. Click Edit next to the preparer name. In the Edit Preparer Information window, 
click the Electronic Filing Info tab and enter the credit card information.)

Batch e-filing allows you to complete client returns while you wait for receipt of payment.

In order to batch e-file client returns, prepare returns for submission by completing steps 
1 through 8 above for each return. Any fees associated with returns for batch submission 
must be paid when completing step 8 above for each return.

1.  Complete steps 1-8 above (for e-filing a single return).
2.  Continue through the “Submit Return” screen.
3.  On the “Create and Submit” screen, choose “Submit Later” in order to place that return 
      into a holding directory.

When you are ready to submit a batch of returns:

1.  Click Preparer in the main menu, then Submit Client E-files. (You can also navigate here 
      from the E-file Center by clicking the second link, Submit (Batch) Electronic Filing Returns.)

2.  A popup window with all client returns ready for submission will appear. Check the 
     returns you would like to submit.

6

8

7

9

E-file multiple returns as a batch
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Note: You can also “delete” a return pending transmission in this window. Deleting simply removes the file from the holding 
directory – it does not delete the return or alter the information in the return. If you delete a file from the holding directory, you 
must again complete steps 1-8 above for e-filing a single return.

3.  After selecting at least one return, the Submit button will be enabled. Click Submit to 
     transmit the selected returns.

4.  When submission is complete, a confirmation window will appear. You should also 
     receive an email notification from TaxAct indicating the returns have been received.

Remove a Client Return

1.  Click the client record in Client Manager.
2.  Click the three-vertical dots menu in the first column or right click the client record, 
     highlight Return, then click Remove.
3.  Click Yes to delete BOTH the tax return file and the client information stored in 
     Client Manager. Click No to cancel.

Search for a Client

Highlight the Search field and enter text. The Search field matches text in Client, SSN/EIN, 
Spouse SSN, Contact Email, E-File Status, or Contact Phone #1 columns.

Print Information in Client Manager

Click the Open Client Manager Print Center button. (See Print Returns, Labels, Reports, 
and Invoices, later).

View Preparer Preferences

1.  Click the View Preferences button.
2.  Choose settings for your Client Manager, Electronic Filing Manager, and specify 
     general preferences.

Work on Files Offline (Local storage only)

All users will be required to authenticate themselves upon initial software startup by 
signing in with their TaxAct Account username and password with an active Internet 
connection. After the initial sign-in, local storage users may work offline. When an Internet 
connection is not detected by the software, you will see a window with a work offline 
option available. Some features will not be available while working offline. To access those 
features, you may need to close your software and re-open to sign in online.

Other Return Actions
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Protect, Backup, and Restore

TaxAct offers several methods for you to 
keep your client returns safe and secure, 
including:

Your practice is issued a TaxAct Account and the practice administrator can set individual 
permissions for each preparer.

Enterprise Editions Online Networking users: All data you enter is backed up 
automatically, so there is no need to run manual backups on your client data files.

•  Password protection
•  Full backup and restore features

In Client Manager, double click to open return.

1.  In the main menu, click File > Passcode > Add.
2.  Enter a passcode in the fields provided, then 
     click OK.

Reminder: Document all of your passcodes in a safe 
location.

If you choose not to add a passcode to the return, 
click Cancel to exit.

Password-Protect Client Returns
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You will be required to sign in each time you open the software and after 30 minutes of 
inactivity on your PC, or every 24 hours (whichever comes first).

The IRS Security Summit’s requirements apply to all professional tax products across the 
industry, including TaxAct Professional’s solutions. For more information, view our FAQ on 
TaxAct Professional, IRS and State Agencies Expand ID Theft Safeguards.

Use the Preparer’s Permission menu to limit which returns each preparer can access.

Note: Make sure to document all passwords for future reference.

Performing regular backups of client information, returns, and preparer information is 
important. To utilize TaxAct’s backup and restore functions, follow these easy steps.

1.  Click File > Backup > Client Return(s).

2.  Select Local and click Next.

3.  Check the box next to the return(s) you want to back up and click Next. (Notes: Click 
     Select All to check all returns. Choose by return type in the drop-down list.)

4.  To change the backup file location, select Browse and choose the location using the 
     directory tree.

5.  Click Finish. A confirmation message will appear when files are backed up.

To back up Preparer Info, click File > Backup > Preparer’s Information > Local, specify 
a backup directory and click Select Folder. When performing future backups, you will be 
prompted to overwrite the files that already exist. Be sure to save the most recent versions.

Networking online? No need to back up your data – it’s automatically saved to TaxAct’s 
secure servers!

Networking locally? We recommend backing up your data both on your computer (following 
the above instructions) and on TaxAct’s secure servers as an extra level of protection:

Set Individual Usernames, Passwords & Permissions

Back Up Client Returns to Your Local Computer

Enterprise Editions: Back Up Client Returns on TaxAct’s Secure Servers

https://www.taxact.com/support/24899
https://www.taxact.com/support/24169/
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1.  Click File > Backup > Client Return(s).
2.  Choose Online, then click Next.

3.  Enter your TaxAct Account username and password.

4.  Select the return(s) you want to back up. (Notes: Click Select All to check all returns. 
     Sort by return type in the drop-down list.)

5.  To back up preparer information, check the box next to Backup Preparer Master 
     Information.

6.  Click Finish to upload the files. A confirmation message will appear when files are 
     backed up.

You may be prompted to overwrite any files of the same name that exist. Be sure you are 
restoring from the correct file before proceeding. A confirmation message will appear 
when files have been restored.

1.  Click File > Restore > Client Return(s).
2.  Choose Local, then click Next.

3.  Browse to your backup location to choose the files to restore. To restore all returns, 
     click Select All. Click Next.

4.  Browse to the restore location. Default is C:\TaxAct\TaxAct 2024 Professional Edition\
     Client Data\[Practice ID]. Click Finish.

A confirmation message will appear when files have been restored.

1.  Click File > Restore > Client Return(s).
2.  Select the Online radio button, then click Next.

3.  Sign in to your TaxAct Account.

4.  Select the return(s) you want to restore. To restore all returns, click Select All.
5.  To restore Master Information at the same time as client returns, check the Restore 
     Preparer Master Information box, then click Next.

6.  Click the Authorize button. This will send an email to the address associated with your 
     account.

Restore Client Returns from Backup Files Saved Locally

Restore Client Returns from Backup Files Saved on TaxAct Servers (Enterprise Editions Only)
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7.  Leaving the TaxAct Restore Wizard open, click the link in the e-mail. Follow the steps to 
     enter the authorization information into TaxAct and submit.

8.  Return to the TaxAct program and click Next.

9.  Browse to the restore location. Default is C:\TaxAct\TaxAct 2024 Professional 
     Edition\Client Data\[Practice ID]. Click Finish.

You may be prompted to overwrite any files of the same name that exist. Be sure you are 
restoring from the correct file before proceeding. A confirmation message will appear 
when files have been restored.

The Print Center

The Print Center offers multiple printing 
options in one convenient place. Multiple 
documents can be printed in one job.

The Print Center also consolidates the 
printing of client returns, organizers, 
consent forms, labels, and blank forms.

You can access the Print Center in any of 
the following ways:

•  Select any Print command under the 
    Preparer top menu,

•  From within a return, click the Print 
    button found in the toolbar under the
    main menu.

•  From within a return, click File > Print 
   Client Returns

Print Returns, Labels, Reports, & Invoices
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Before printing, make sure to set your printer preferences by following these steps:

1.  Click File > Print Setup.

2.  Select printer and modify property settings if needed (default printer settings will 
     generally allow you to successfully print documents from TaxAct),then click OK.

When printer preferences are set, continue with printing:

1.  Click Preparer > Print Returns. This will open the Print Center window.

2.  Click the Client Returns tab. Select the return(s) to print, or click Select All to print all 
      returns at once.

3.  Enter quantities for each desired document.

4.  Click Select States or Select Reports to print related materials, then click Print.

Print a Client Return
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TaxAct’s bank partners require taxpayers 
to sign an agreement document before 
transactions can be processed. To print the 
document(s) with client returns:

1.  Click Preparer > Print Consent Forms. 
      The Print Center window opens.

2.  Click the Consent Forms tab.

3.  Select the Client and Bank.

4.  Enter the desired number of copies, 
     then click Print.

Print Consent Forms
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What is a Client Organizer?

The Client Organizer is a portfolio of client return information designed to help you obtain 
tax information in advance. Imported returns will include prior year tax information to 
compare with the current tax year.

The Client Organizer portfolio includes:

• A Cover Sheet

• Personal Information

• Income

• Deductions

• Payments

To print Organizers, click Preparer in the top menu, then Print Organizers.

Print Client Organizers

1.  Select the clients for whom you want to 
     create Organizers.

2.  Select the Print Applicable Organizers 
     radio button to print only the documents 
     that directly apply to the client’s return. 
     To choose specific Organizer documents 
     to print, select Print Selected 
     Organizers instead.

3.  Select the items to include in the 
     organizer, then click the Print button.
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From the Print Center, click the Labels tab. You have three options:
•  Print Client Labels •  Print Preparer Labels          •  Print Other Labels.

Setting Label Properties

To format labels, click Label Properties. 

1.  Set the print job based on your printer type and label size.

2.  Click Set Font to access a list of available fonts and modify the text style and size.

3.  Once you have set your preferences for the labels to print, click Print.

Print Labels

Client Labels

1.  Select the client(s).

2.  Select Show All Clients or Show Federal 
Estimated Tax Payment Clients.

3.  Choose options for printing Married 
Filing Joint clients.

Preparer Labels

To print return address labels:

1.  Choose the preparer.

2.  Edit the address shown if needed.

Print Other Labels

You can customize address labels for 
other uses, such as paper-filed returns, 
tax payments, and personal messages to 
include on client correspondence.
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You can print any of the following reports in the Print Reports menu:

•  Adjusted Gross Income
•  Average Client Fees
•  Billing
•  Client Manager

Custom Reporting 

Choose this option to 
select which clients and 
information fields you’d like 
to export to a CSV file.

To change the display 
order, click the appropriate 
field name within the Fields 
Included box. Then click on 
Move Up or Move Down 
until the fields are in your 
preferred order.

•  Contact List
•  Mailing List
•  Practice Summary
•  Self-Employment

•  Update Summary
•  2024 Federal Estimated 
    Tax Payments
•  Custom Reporting

Print Reports From Preparer Menu



56

Available reports include:

•  Adjusted Gross Income
•  Average Client Fees
•  Billing – Paid
•  Billing – Unpaid

1.  From within Client Manager, select a client. and right click.

2.  Click Print and then select the Reports tab in the Print Center dialog to select a report   
     to print.

•  Billing – All
•  Client Manager
•  Contact List
•  Mailing List

•  Practice Summary
•  Self Employment
•  Update Summary
•  2024 Estimated Payments

Print Invoices and Billing Statements from Client Reports Tab



57

Integrated Payments

TaxAct Practice Manager
In your TaxAct Professional Account, under “Practice Manager”, there is a button called 
“Integrated Payments by Drake Pay”

Applying for Integrated Payments
After clicking the button, select “Apply Now”
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Follow the instructions on the top of the page to complete the application. You may 
receive a follow up email to complete your application or to supply any additional needed 
information. 

It may take 1-3 business days for your application to be processed once complete. You 
can check the status of your application in the Practice Manager dashboard, or by visiting 
the new “payments” tab in the TaxAct Professional Software. 
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Collecting Payments
To collect a payment from a client with a balance due, go to the “client manager” tab and 
right click on a client. Then click the “Collect payment” option. 

If your application hasn’t been completed yet, this option will display your application status. 
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Payments Tab
A successful payment will be displayed in the Payments Tab. Here, you can view all 
previous payment history. 

Assuming your application has been accepted and approved, simply fill out the client card 
information including the Amount to Pay, which is the amount that will be charged. Then, 
press “Process Payment”.  
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Here, you can view details about the payment, as well as send a client refund by clicking 
the “refund” option. 

To refund a payment, click the 3 dots next to the desired payment and click “Details”. 
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To allow your preparers to access Integrated Payments, go to the navigation bar at the 
top of the screen and click Preparer > Master Information > Preparers. Then, click the 
Pencil icon next to the preparer name to edit permissions for that preparer under the 
Permissions tab. At the bottom, select “Allow” for both Payment Collection and View 
Payment Manager, then click Save and Close. Now, this preparer will be able to use all 
the features of Integrated Payments. 
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Additional Resources

Professional Reports

TaxAct Professional Reports are accessible from your TaxAct Account (Practice Manager) 
or from within your Professional Edition software. TaxAct Professional Reports provides 
you with summary and detailed information about e-files by status, EFIN, PTIN, and 
settlement type.

Refer to the Professional Reports Guide to learn how to access the reports and navigate 
through the system.

Client Xchange

Client Xchange is a convenient and secure website portal that enables you and your 
clients to safely exchange tax information from any device with internet access. Easily 
upload and download all the tax information you and your clients need to share in 
seconds – from photos of Form W-2s and receipts, to CSV files of stock transactions and 
PDFs of client organizers and final tax returns.

If you are a single-preparer office, sign in to your account and click on the Client Xchange 
tile to purchase. Otherwise, talk to your practice owner today about purchasing Client 
Xchange. (In order for all preparers in a practice to have access to Client Xchange, it must 
be purchased by your practice owner.)

Refer to this guide to help set up your Client Xchange website, invite clients and manage files.

Bank Products

TaxAct Professional offers tax-related Bank Products such as Refund Transfers, Cash 
Advances, and Software Purchase Assistance. See taxact.com/professional/bank-products 
for more information.

        www.taxact.com/professional

        professional@taxactservice.com

        (319) 371-2682

https://www.taxact.com/professional/resources/setupguide
https://www.taxact.com/auth/
https://www.taxact.com/professional/resources/xchange
https://www.taxact.com/professional/bank-products
http://www.taxact.com/professional/
mailto:professional%40taxactservice.com%20?subject=

