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1. INTRODUCTION 

The Model 881L is an advanced mechanical scanning, high-frequency, high-resolution pipe profiling sonar 

system that has been designed to provide simple, reliable, and accurate representation of inner bores of fluid 

filled pipes and cavities. The 831L is connected via ethernet and the sonar is therefor able to transfer data at a 

higher rate which leads to improved range resolution. It is designed to work horizontally with the sonar scanning 

vertically, but may be orientated vertically, with sonar scanning horizontally. However, in this configuration 

(dropped vertically) the pitch and roll sensor will not be able to work.  

The sonar comes with a free Windows™ program that is used to interface with the sonar, control settings, log 

and play back data. 

The general features are: 

Frequency 2.25 MHz 

Transducer Profiling type, fluid compensated 

Range Resolution 0.5mm 

Maximum Operating Depth 1000m 

Transducer Beam Width 1.4° Conical 

Minimum Detectable Range 50 mm (6”) 

Table 1 General Features 
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2. GETTING STARTED 

The following bullet points describe the set-up procedure of the 831L: 

• Physically mount the sonar or connect it to the down-pipe payout arrangement. Do not clamp the sonar 

anywhere on the red polyurethane section as detailed below (See Figure 1 External View) 

• Connect the supplied underwater cable to the sonar Subconn MCIL8F connector (see APPENDIX C 

Cable Diagram (831L) for cable pin-out).  

• Ensure 24VDC (1A minimum) power supply is off. 

• Connect the cable counter system (if relevant) to the PC serial port. 

• Configure the network card’s IP address. (see Sections 3.9.2 System > IP Address) 

• Connect the RJ45 connector to the PC’s network port. 

• Power up the 831L. 

• Launch the PipeSonarL_vxxxx.exe program (where xxxx is the latest version), and commence 

operations.  
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2.1. HARDWARE INSTALLATION 

2.1.1. Personal Computer 

The minimum requirements for the user supplied PC are: 

• Intel i5 or equivalent. 

• Windows™ 7. 

• 8 GB RAM. 

• Minimum software screen resolution is 1024 x 768. 

• 1 TB Hard drive. 

• An available discreet Gigabit Ethernet port, supported by a Realtek PCIE GBE family chipset (not an 

FE family chipset) must be used. If an external Ethernet to USB adapter is used, a high specification 

USB 3.0 Gigabit Ethernet Adapter is recommended. The TP-LINK Model UE300 appears to work well.  

• If a cable counter is used an available RS-232 port is used. If no COM port is present on the PC, an 

RS-232 to USB adaptor is used. The UC-232A USB to RS-232 from ATEN appears to work well. 

 

Refer to Document Number 410-013. ‘USB Converters and the Windows OS’ for important information on 

USB <--> RS232 and USB <--> RS485 Converters running on Windows operating systems (available on 

the Imagenex Corp website https://imagenex.com/support). 

 

  

https://imagenex.com/support
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2.1.2. Sonar Considerations 

 

Figure 1 External View 

 

A FRAGILE. This area must not be obstructed. Do not attach any brackets or fastenings to this area. 

B Ensure locking sleeve is used. Do not bend pins. 

C Do not remove. Represents transducer down position. 

D Use this area to mount the sonar. 

Table 2 External Hardware 

  

A 

B 
C 

D 
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2.2. SOFTWARE SETUP 

The latest version of the Win831L program is available from the Imagenex Technology Corp. website 

(https://imagenex.com/interior-page/software-download). The installation of the software on the PC is 

straightforward. It can be installed in its own directory, and run by double clicking, or by the creation of a shortcut 

on the desktop for it. It is not recommended that the “New Program Wizard” nor any other installation program 

be used. 

If present, a Win881AL.INI file will be read and the settings from the previous time the application was run will 

be used.  

  

https://imagenex.com/interior-page/software-download
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2.3. INTERFACE 

  

Figure 2 Software User Interface (File Playback)  

 

  

Freq / Gain 

Diagnostics 

Range 
Shortcut Buttons Playback Bar 

Sonar Pitch, Roll 

and Distance 

 

Settings 

Status Bar 

Transducer Orientations (see System > 

Transducer Orientation) 
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2.3.1. Shortcut Buttons 

 

Connect to a physical sonar head. 

 
Open a file play-back session. 

 
Start / Stop recording an 31L data file.  

 

Increase sonar range. 

 

Decrease sonar range. 

 

Increase sonar gain. 

 

Decrease sonar gain. 

 

Increase sonar sector around train zero point. 

 

Decrease sonar sector around train zero point. 

 

Train left. Rotates head zero point to the left 

 

Train right. Rotates head zero point to the right 

 

Pauses real-time or playback. 

 

Restore default zoom and pan. 

 

Zoom in display. 

 

Zoom out display. 

 

Displays a circle whose attributes can be set (see 3.5 Pipe Shape). 

 

Allows moving of circle described above 

 

Allows text to be added to the screen whose attributes can be defined (see 3.6 Text). Click Text > Delete to 
clear. 

 
Ruler. Measures distance in metres or feet (depending on Options > Units selection) on the display. See 3.7 
Measure) Click Measure > Erase to clear. 

 

Refreshes display, clearing any text or measurements on the screen. Doesn’t currently clear data only text 
and measurements 

 

Display Diagnostics dialog box. 
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Opens a window with speed keys and other settings (See Appendix A). 

Table 3 Shortcut Buttons 

2.3.2. File Playback 

 
Table 4 Playback Control 

Used during playback and allows the user to adjust the playback speed and file position. 

2.3.3. Sonar Settings 

Used to control various sonar attributes. Only available in real-time mode: 

 

Figure 3 Sonar Settings 

 

• Range: Set the maximum range of target detection. (0.125m - 6m). 

• Gain: Set the sonar gain. (0 - 40 dB). Adjust until display optimized. 

• Sector: Define the scan sector (0° – 360° in 3° increments). 

• Train: Allows for the rotation of the sector (set above) around the centre (0° – 360° in 9° increments). 

• Profile: Define the profile display (High Mix, Medium Mix, Low Mix, Points Only or Off).  

 

  



831 L Scanning Sonar   

 

Doc No: 430-044-0A           Page 18 of 39 

2.3.4. Pitch, Roll and Depth 

The following graphic appears bottom left of the main display: 

 

Figure 4 Bottom Left 

P: Sonar pitch (+ve pitch bow up). 

R: Sonar roll (+ve starboard down). 

D: Distance. Only updated if the external Orientation Input (see 3.9.1 System > COM Port Setup) is enabled so 

that cable payout can be monitored. 

Note that the pitch and roll may be derived from either the integrated pitch and roll sensor, or from external 

sources through an Inuktun string unit. Selection for the P and R source are made in 3.2.13 View > Use External 

Pitch / Roll Data. If external pitch and roll are selected, the Inuktun string must be enabled in 3.9.1 System > 

COM Port Setup. 
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3. SOFTWARE MENUS 

3.1. FILE 

3.1.1. File > Connect to Sonar Head 

Select data source to be from the sonar head and viewed in real-time.  

3.1.2. File > Open File to Playback 

Data can be replayed from a previously recorded file from the Open File dialog box. 

3.1.3. File > Record Start (Stop)… / Copy Start (Stop)… 

Record Start (Stop) - Realtime only. 

Copy Start (Stop) - Playback only. 

Toggles the record state on / off. Recording is done as per the settings below. The file format for an 831L is 31L. 

3.1.4. File > Set Record Directory 

Specify the directory in which files are saved. If nothing is specified, the program saves the copied / recorded 

files to the directory from which the software was run.  

3.1.5. File > Convert .31L to XYZ 

Converts an .31L data file to an ASCII text XYZ file. X and Y are the output from a polar to rectangular conversion, 

and z is calculated from the cable payout value of the Inuktun string if enabled (see 3.9.1 System > COM Port 

Setup). X,Y and Z values are corrected for pitch and roll. An Open File dialog box is shown and a file is selected, 

which is replayed and an XYZ file generated in the background. Realtime mode will stop during this process. 

The XYZ is formatted as dd-mm-yyyy<tab>hh:mm:ss<tab>X<tab>Y<tab>Z<cr><lf> 

3.1.6. File > Auto Save File Names 

Select the file name set automatically as Win831L DD-MMM-YYYY HHMMSS.31L. 
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3.1.7. File > Auto File Size 

Realtime only. 

Select the file size to be limited to 1 – 4 Gbytes. If selected, data will be logged to the maximum file size and a 

new file will be created to continue logging. 

3.1.8. File > Enable UDP XYZ Output 

Enables the output of the format DD-MMM-YYYY,HH:MM:SS.mmm,X.XXX,Y.YYY,Z.ZZZ<CR><LF>, to an IP 

address and UDP port specified. The UDP port is edited in the PipesonarL.ini associated with the executable 

and the following tags are relevant: 

Output UDP Address=xxx.xxx.xxx.xxx 

Output UDP Port=xxxx 

Edit the xxxs for a valid IP address and UDP port. 

3.1.9. File > Enable UDP Range / Bearing Output 

Enables the output of the format Date,Time,Pitch,Roll,Distance,Range,Bearing, to an IP address and UDP port 

specified.  The UDP port is edited in the PipesonarL.ini associated with the executable and the following tags 

are relevant: 

Output UDP Address=xxx.xxx.xxx.xxx 

Output UDP Port=xxxx 

Example: 

DD-MMM-YYYY,HH:MM:SS.mmm,ppp.ppp,rrr.rrr,ddd.ddd,RRR.RRR,BBB.BBB<CR><LF> 

where, 

DD = day 

MMM = month 

YYYY = year 

HH = hours 

MM = minutes 
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SS = seconds 

mmm = milliseconds 

ppp.ppp = pitch angle in degrees 

rrr.rrr = roll angle in degrees 

ddd.ddd = distance in meters 

RRR.RRR = range in meters 

BBB.BBB = bearing in degrees 

3.1.10. File > Save Screen 

Opens a dialog box that allows for the saving of a BMP file of the current screen. 

3.1.11. File > Exit 

Writes all settings to the Win881AL.INI file that is kept in the same location as the executable file, and closes the 

program. The next time the program is started, the system will load these settings from the .ini file. 

3.2. VIEW 

3.2.1. View > Clear Image 

Refreshes screen and clears the current profile image. Any circle, text and measurements that are on the screen 

will remain. 

3.2.2. View > Hold 

Pause the display of sonar data. 

3.2.3. View > Reverse 

Realtime only. 

Changes the sweep direction. Toggles clockwise / counter-clockwise. 

3.2.4. View > Restore Image 

Restores the previously set graphics view. Undoes the most recent changes. 
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3.2.5. View > Zoom Factor 

Changes the factor by which the display is zoomed in or out (50, 75, 100, 125, 150, 175, 200, 300%). 

3.2.6. View > Zoom In 

Shortcut button:  

Zooms in by the factor specified in Zoom Factor.   

3.2.7. View > Zoom Out 

Shortcut button:  

Zooms out by the factor specified in Zoom Factor.   

3.2.8. View > Range Marker 

Displays / hides the range, frequency and gain information on the top left of the display. 

3.2.9. View > Diagnostics 

Displays / hides the Diagnostics window. 

3.2.10. View > Sonar Settings 

Realtime only. 

Displays a window for setting Range, Gain, Sector, Train and Profile. 

3.2.11. View > Background Color 

Allows for the change of background color through a color palette. 

3.2.12. View > Display Pitch / Roll / Distance 

Displays a window showing the current orientation and distance of the sonar. See 2.3.4 Pitch, Roll and Depth. 



831 L Scanning Sonar   

 

Doc No: 430-044-0A           Page 23 of 39 

3.2.13. View > Use External Pitch / Roll Data 

The above window may be updated from an internal pitch and roll sensor, or from an external input from a COM 

port. The Inkutun string has fields that contain the pitch and roll (and distance) and this string may be used to 

update the program pitch and roll. See 3.9.1System > COM Port Setup 

3.3. COLOR TABLE 

Allows various color combinations (background and scan) to be selected.  

Used to change the sonar data color palettes for the sonar images. The 831 L GS uses a color table to represent 

echo data strength (amplitude). For example, the Normal High intensity color table maps the echo data amplitude 

to 256 colors ranging from black (low strength level) through blue, green, orange yellow white and red (highest 

strength level). 

The Color Table menu offers the following options: 

Normal High Standard color table used for mapping the echo data amplitude to 256 colors ranging from 
black (low level), through blue, green, orange, yellow, white and red (highest level). 

Normal Low Same colors as Norm Hi, but uses a lower color intensity. 

Green 256 shades of green. 

Grey 256 shades of grey (white on black). 

Reverse Grey 256 shades of grey (black on white). 

Brown/Yellow 256 mixed shades of brown and yellow. 

Green/Blue 256 mixed shades of green and blue. 

Green/Yellow 256 mixed shades of green and yellow. 

Blue 256 shades of blue. 

Table 5 Color Table 
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3.4. POINTS 

3.4.1. Points > Points Color 

Allows for the change of points color through a color palette. 

3.4.2. Points > Small / Medium / Large 

Specify the desired point size. 

3.5. PIPE SHAPE 

3.5.1. Pipe Shape > Circle / Horse Shoe 

Define the pipe shape for the display drawn when using the  toolbar button. This sets an overlay on the 

screen according to the attributes set in the rest of the menu (like diameter), whose shape is either a circle or 

horseshoe shape. The diameter or width is set, depended on whether a circle or horseshoe is selected. See 

(3.5.4 Pipe Shape > Pipe Diameter). 

3.5.2. Pipe Shape > Move Shape 

Only available if a shape is on the screen. Toggle on / off for the dragging of the shape to the desired position. 

3.5.3. Pipe Shape > Line Color 

Allows for the change of shape line color through a color palette. 

3.5.4. Pipe Shape > Pipe Diameter 

Changes the pipe diameter (or horse shoe shape). 

3.5.5. Pipe Shape > Display Overlay 

Toggle display of overlay shape (as defined in Circle / Horse Shoe) on / off 
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3.6. TEXT 

Shortcut button:  

3.6.1. Text > Input… 

Allow text to be written to the screen and can be used in conjunction with File > Save Screen to associate user 

comments with scans. 

3.6.2. Text > Delete 

Delete all text from the screen 

3.6.3. Text > Text Color 

Allows for the change of text color through a color palette. 

3.6.4. Text > Small / Medium / Large / Larger / Largest 

Change the font size. 

3.7. MEASURE 

Shortcut buttons  

3.7.1. Measure > Add 

Click first point, then move rubber band to second point and click. The dimension will then be annotated onto 

the screen.  

3.7.2. Measure > Delete 

Delete all annotated measurements from the screen. 

3.7.3. Measure > Line Color 

Allows for the change of measure line color through a color palette. 
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3.8. GRID 

3.8.1. Grid > None / Rectangular Grid / Polar Grid 

Choose a presentation of grid from: 

• None: No grid. 

• Rectangular: Equally dimension X and Y grid. 

• Polar: Concentric circles. 

3.8.2. Grid > Grid Color 

Allows for the change of grid line color through a color palette. 

3.8.3. Grid > Solid Line / Dotted Line / Dashed Line 

Select line style. 

3.9. SYSTEM 

3.9.1. System > COM Port Setup 

Realtime only. 

Open a dialog box for the serial setting of an optional Orientation Input. Click enable and enter COM port, baud 

rate and sentence type. 

The expected input format is as follows: 

Inuktun: $PITCH±DD.D,ROLL±DDD.D,DIST±DDDD.DD<CR><LF> 

Cable Count: $<space>DD.D,meter where DD.D is metres along track. 

Note that if Cable Counter selected, there is no external orientation information. 

3.9.2. System > IP Address 

Realtime only. 

Allows for the configuration of the Internet Protocol (IP) address for incoming sonar data. 

The statically assigned default for the sonar IP Address is 192.168.0.5 and unless a different IP address was 

selected at the time of ordering, this should be used and is set in the Sonar IP Address textbox. 
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3.9.3. System > Diagnostics 

Displays a window showing various diagnostic information relating to the sonar. 

3.9.4. System > Show System Settings 

See 3.2.10 View > Sonar Settings. 

3.9.5. System > Minimum Range 

Allows for the setting of a minimum range. If a range is measured that is closer to the sonar head than this range, 

the range is not plotted and not recorded. This should be used with caution so as not to eliminate wanted data. 

3.9.6. System > Sound Velocity  

If the sound velocity is known, it is set here. Ranges are calculated according to the sound velocity set. 
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3.9.7. System > Transducer Fwd / Aft  

Select according to the mounting orientation: 

 

Figure 5 Transducer Forward 

 

Figure 6 Transducer Aft 

 

  

Travel Forward

Travel Forward
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3.9.1. System > Zero Up / Down  

Select according to the mounting orientation: 

 

Figure 7 Zero Down 

 

Figure 8 Zero Up 

 

For both Transducer Fwd / Aft and Zero Up / Down, a screen graphic indicator (bottom right) shows the 

orientation set: 

•  Transducer Fwd, Zero Up. 

•  Transducer Fwd, Zero Down 

•  Transducer Aft, Zero Up 

•  Transducer Aft, Zero Down 

3.10. OPTIONS 

3.10.1. Options > Units 

Metres or feet can be selected as the units used. 

Travel Forward

Travel Forward
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3.10.2. Options > Set Default Colors 

Restores the background color palette to the default black. Points remain as per the selected color table color. 

3.10.3. Options > Delete All Drawings 

Deletes any text or measurements made on the background. 

3.10.4. Options > Roll Correction 

Toggles roll correction on / off. Applies measured roll to all points and plots the roll corrected data. 

3.10.5. Options > Calibrate  

Not used 

3.11. PROFILE 

3.11.1. Profile > Off  

Only image data is displayed (i.e. no profile points). 

3.11.2. Profile > Points only  

Only generated profile points are displayed and no image data is visible. 

3.11.3. Profile > Low Mix 

Image data is displayed at quarter intensity along with the generated profile points. 

3.11.4. Profile > Medium Mix 

Image data is displayed at half intensity along with the generated profile points. 

3.11.5. Profile > High Mix 

Image data is displayed at the normal intensity along with the generated profile points. 
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3.12. HELP 

3.12.1. Help > Help… 

Displays a pane with hot keys. (see APPENDIX A) 

3.12.2. Help > About PipeSonarL… 

Reports the software revision which should be quoted during any support queries. 
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4. ADDITIONAL DOCUMENTATION 

Document Number Description 

430-054 881L Ethernet Troubleshooting Guide 

425-019 File Format Specification 

425-020 Ethernet Specification 

410-013 USB Converters and the Windows OS 

Table 6 Additional Document 
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APPENDIX A HOT KEYS 
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APPENDIX B SPEC SHEETS 
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APPENDIX C CABLE DIAGRAM (831L) 
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