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Medication Reviews – New Brunswick 
This document outlines how to configure Medication Review functionality in Kroll and the 
process of completing Medication Reviews for both paper based and electronic records. 

Configuration 

This section explains the configuration settings that must be in place before attempting to use 
the Medication Review functionality. 

Configuring Electronic Signatures 

NOTE: Only complete this section if you are using Electronic Signature pads. 

Before you can begin configuring electronic signatures, Allow Electronic Signatures must be 
enabled in File > Configuration > Kroll > Configuration. This will require a support call and must 
be completed before proceeding.   

 

 Go to File > Configuration > Store > General. 1.

 Place a checkmark next to Allow Electronic Signatures. 2.

 

 Click OK to save the changes. 3.
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Configuring Electronic Medication Reviews 

 Go to File > Configuration > Store > Rx > Counseling > Med Reviews/Dialogs. 1.

 

 In the Med Reviews/Dialogs area above, ensure the following options are set appropriately. 2.

 Require Document Scan to Complete Paper Med Review: this option  allows you to 
complete paper-based Medication Review using the document scan functionality; 

 Enable Electronic Med Reviews: enabling this option allows you to use the electronic 
version of Medication Review; 

 Require Electronic Signature: enabling this option prompts for electronic signatures 
where necessary (only if you are using Electronic Signature pads). 

 Allow Editing Counseling Time: this option allows you to modify the system-calculated 
amount of time it took to complete the counseling session. 

 Click OK. 3.
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NOTE: If you turn off the Require Electronic Signature option and keep the other options 
enabled you will still be able to complete the reviews on-screen. However, you will need to 
print the report, in order to capture pen-to-paper signatures and then scan it back into the 
system before giving it to the patient. 

Electronic Medication Reviews 

This section explains how to perform an Electronic Medication Review. Ensure your system is 
configured for Electronic Medication Reviews before proceeding. See Paper Medication Review 
for information on the non-electronic process. 

NOTE: The automatic prompts will not appear if the patient does not meet the criteria for a 
Medication Review. However, based on other available information and your professional 
judgement, you can determine whether the patient might benefit from a Medication Review 
and then manually create a Medication Review. 

Configuring the Medication Review Prompt  

The system prompts for Medication Review when the option Prompt for Medication Review is 
enabled under File > Configuration > Store > Rx > Prompting. 
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When the option ‘Prompt for Medication Review’ is enabled, the system screens each patient 
for Medication Review eligibility every time an Rx is processed. If the patient is eligible, the user 
is prompted and presented with a number of options as shown below. 

 

 Add to Med Review Queue: Selecting this option adds the Med Review record to the 
Medication Reviews queue which can be accessed from the Patient record or  
F9 – Workflow. See section ‘Completing Medication Reviews ‘Saved for Later’ for 
further details. 

 Do not prompt me until the next time the patient comes in: This will suppress 
prompting for today. The next time the patient comes in to fill an Rx, you will be 
prompted for the Medication Review.  

 Do not prompt until: This will allow you to dismiss the prompt for a specified number of 
days, or until a specified date, after which the prompt will appear.  

 Never prompt for this patient: This will suppress any further prompts for this patient. 
This option is only available if the configuration option of Allow ‘Never Prompt’ for 
Medication Review is enabled.  

 Undecided: The prompt will re-appear once again the next time a prescription is filled 
for the patient. 
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Creating an Electronic Medication Review (Manual) 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogs from the right navigation pane.  2.

 

 The Medication Review profile will appear. Click N – New Review/Dialog. 3.

 

 The Medication Review/Dialog screen will appear. Select a review type from the dropdown 4.
menu and click Perform Now. If you wish to add to the Med Review queue in order to 
complete the Medication Review later, click Save for Later. 
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 The Medication Review Rx Selection screen will appear. Rxs under the Pre-Selected tab are 5.
selected by default; Rxs on the other tabs are not. Proceed through each tab and check the 
Rxs you want included in the report. When you are finished, click OK. 

 

 The NB PharmaCheck Medication Check-up screen will appear. Click Next to proceed 6.
through the tabs, completing the required fields as you go.  

NOTE: The type of review that is displayed on screen depends on what type of review was 
selected in Step 4. In this example, the NB PharmaCheck Medication Check-up screen 
appears. 
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Questions  

The Questions tab includes a list of questions that the pharmacist is to ask the patient to better 
understand their situation. Answers are recorded by selecting the appropriate option from each 
dropdown menu. 

  

Medical History 

The Medical History tab displays the medications that have been selected on the Medication 
Review Rx Selection screen. 
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For each medication listed: 

 Note if the patient is currently taking the specified medications and select Yes/No from 
the dropdown list. 

 Enter the reason for using the medication based on the patient’s feedback in the 
Indications field. 

 Enter any general comments in the Comments field. 

Use the Del button to delete a record from the Medical History tab. 

Non-Prescription Medications  

The Non-Prescription Medications tab provides space to record any OTC/non-prescription 
medications the patient is taking. 

Click Ins to add a non-prescription medication to the tab. 

 

 Note if the patient is currently taking any OTC medications and select Yes/No from the 
dropdown list. 

 Enter the name of the medication in the Medication field. 

 Enter any appropriate comments in the Comments field. 

Use Del buttons to remove any OTC items. 
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Rxs From Other Pharmacies 

The Rxs From Other Pharmacies tab provides space to record medications that the patient is 
taking that were filled in other pharmacies. 

Click Ins to add an Rx from another pharmacy. 

 

 Note if the patient is currently taking any other medications and select Yes/No from the 
dropdown list. 

 Enter the name of the medication in the Medication field. 

 Enter any appropriate comments in the Comments field. 

Repeat the same process for any Rx items that they have purchased from other pharmacies. 
Use Del buttons to remove any Rx items. 
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General Comments 

The General Comments tab provides space to record any comments you want included on the 
report printout. 

 

Pharmacist Comments 

The Pharmacist Comments tab provides space to record any comments that the pharmacist 
wishes to enter concerning the medication or patient in the free form. 

 

 When you are finished click Finalize Review. 7.
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 The Medication Review prompt will appear. If you have Allow Editing Counseling Time 8.
enabled, enter the amount of time it took to complete the review in the Time spent field.  

The Assessment Location information is pre-populated with the pharmacy information. If 
the Medication Review was physically conducted in another location (LTC facility, patient’s 
home) other than the pharmacy, enter the name of the location and the address. Complete 
the Other Professional Involved fields if another health professional assisted with the 
review. 

When you are finished, click OK. 
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Affixing an Electronic Signature 

NOTE: If you do not have an electronic signature configured, print the Medication Review 
Report, have both the patient and the pharmacist sign the report, and scan it back into the 
system.  

 Have the patient sign his or her name on the electronic signature tablet. Click the OK button 9.
on the signature tablet. 

 

The patient signature appears once the patient signs on the electronic signature tablet. 
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 Have the pharmacist sign the electronic signature tablet.  10.

 

 When you are finished, tap Done on the signature tablet. 11.

Printing a Medication Review 

 A prompt will appear asking if you want to print a paper copy of the electronic Medication 12.
Review. Click Yes. 

 The Medication Review report print form will appear. Select the appropriate print options 13.
and click Print and provide this copy to the patient. 

Billing a Medication Review 

 Once printing is complete, the Fee For Service claim will automatically populate in the F12 14.
screen. If necessary, perform a doctor search to locate the pharmacist to use as the 
prescriber and ensure all of the other information entered on the F12 screen is correct. 

NOTE: If the user account of the pharmacist logged into the terminal during the processing 
of the Medication Review includes a license number that is identical to the license number of 
a Prescriber card in the Doctor file, then the Prescriber field on the F12 screen for the claim 
will be populated with that prescriber. 
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 Click F12 - Fill Rx. The claim will be transmitted to the appropriate party for payment. 15.

  

Medication Review Options 

Several Medication Review options are available from the right navigation pane on the NB 
PharmaCheck Medication Check-up screen. 
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Review 

Print Medication Review 
When this option is selected, the Medication Review report screen will appear, allowing you to 
set various print options. Configure the appropriate print options. Select Preview to view the 
report or Close to exit. 
 

 

Select Rxs for review 

If you wish to add/edit Rxs on the Medical History tab, click the button Select Rxs for review. 
When selected, the Medication Review Rx Selection screen will appear, allowing you to add 
and remove items from the Medical History tab on the Medication Review Annual Review 
screen. Click OK to save any changes and Cancel to close the screen.  
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View Follow Ups 

When this option is selected, the Medication Review Follow-ups screen will appear, allowing 
you to create follow-up reviews for the patient.  

NOTE: This is something that you initiate to follow up with the patient after the Medication 
Review has been completed. This is NOT a Medication Review Followup review. 

 

To add a follow-up, click Ins and complete the Medication Review Follow-up screen. When you 

are finished, click Save. 
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View 

Patient Charting 

When this option is selected, the Patient Charting form will appear, displaying information 
about the patient’s weight, height, blood pressure, blood sugar, and so on.  
 

 
Use the F2, Ins, and Del buttons to modify, insert, or delete information on this screen. Click 
Print to print or Cancel to close the screen. 
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Patient Documents 

When this option is selected, the Patient Document List will appear displaying a list of 
documents associated with the patient.  
 

 

Use the F2, Ins, and Del buttons to modify, insert, or delete a patient document. Click Close to 
exit the screen. 

Patient Medication Reviews 

When this option is selected the Patient Medication Reviews and Dialogs screen will appear, 
displaying a history of all reviews for the patient including any that are currently in the 
Medication Review queue. 
 

 
 
Double-click a Medication Review to view its details. Click Close to exit the screen. 

Profile 

The Profile menu on the Medication Review Annual Review screen is identical to the Profile 
menu on the patient profile. This menu allows you to view All Rxs, Active Rxs, Active Rxs w/ 
Passtimes, Pricing Profile, and Not Disp/OTC Profile. 
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Completing Medication Review ‘Saved for Later’ 

 To call up Medication Reviews ‘Saved for Later’ or added to the Med Review Queue via 1.
auto prompting, do one of the following: 

Patient Card 

a) Bring up the patient card using the F3 Patient search and select Medication 
Review/Dialogs from the right navigation pane.  

b) The Medication Reviews queue appears with all the Med Review records that are pending 
review. 

 

c) Select the Medication Review record you want to complete and click F - Call Up. 

F9 - Workflow 

a) Select F9 - Workflow from the Alt-X Start screen and select Medication Reviews from the 
right navigation pane. 

b) The Medication Review queue will appear. Select the Medication Review you want to 
complete and click F - Call Up. 

 

 Complete steps 3-8 of the Creating an Electronic Medication Review section. 2.
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Sample Electronic Medication Review Report 
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Viewing a Completed Medication Review 

With Electronic Signatures Enabled 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogues from the right navigation pane. 2.

 Highlight the completed Medication Review and click F2 - View Details. 3.

 

 The NB PharmaCheck Medication Check-up screen will appear. Click the various tabs to see 4.
the Medication Review information that has been entered.  

 

 Click Print to print the Medication Review, or View Signatures to view the pharmacist’s or 5.
patient’s electronic signature. 

Scanned Reviews with Manual Signatures 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogues from the right navigation pane. 2.

 Highlight the completed Medication Review and click F2 - View Details. 3.
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 The NB PharmaCheck Medication Check-up screen will appear. The Review tab displays 4.
information entered on-screen during the Medication Review; the Documents tab displays 
the scanned image of the signed Medication Review. Scanned paper Medication Reviews is 
also viewable from Patient Documents. 

 

 Click Print to print the Medication Review.  5.
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Paper Medication Reviews 

This section explains how to perform paper Medication Reviews. Paper Medication Reviews 
must be completed on paper, signed, and scanned back into the system. 

NOTE: The automatic prompts will not appear if the patient does not meet the criteria for a 
Medication Review. However, based on other available information and your professional 
judgement, you can determine whether the patient might benefit from a Medication Review 
and then manually create a Medication Review. 

Configuring the Medication Review Prompt  

The system prompts for Medication Review when the option Prompt for Medication Review is 
enabled under File > Configuration > Store > Rx > Prompting. 
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When the option ‘Prompt for Medication Review’ is enabled, the system screens each patient 
for Medication Review eligibility every time an Rx is processed. If the patient is eligible, the user 
is prompted and presented with a number of options as shown below. 

 

 Print Report Now: This will call up the Medication Review report so you can select the 
items you would like to print on the report.  

 Print Report Later: This places a record in the Medication Review queue allowing you to 
print the Medication Review at a later date or time. See section ‘Completing Medication 
Review ‘Saved for Later’ for further details. 

 I have Other Rxs to fill for this patient: This will allow you to continue filling more Rxs 
for the patient before printing the report.  

 Do not prompt me until the next time the patient comes in: This will suppress 
prompting for today. The next time the patient comes in to fill an Rx, you will be 
prompted for the Medication Review.  

 Do not prompt until: This will allow you to dismiss the prompt for a specified number of 
days, or until a specified date, after which the prompt will appear.  

 Never prompt for this patient: This will suppress any further prompts for this patient. 
This option is only available if the configuration option of Allow ‘Never Prompt’ for 
Medication Review is enabled.  
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Creating a Paper Medication Review (Manual) 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogs from the right navigation pane.  2.

 

 The Medication Review queue will appear. Click N – New Review/Dialog. 3.

 

 The Medication Review/Dialog screen will appear. Select a review type from the dropdown 4.
menu and click Print Now. If you wish to add to the Med Review queue in order to print the 
Medication Review later, click Save for Later. 
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 The Medication Review Rx Selection screen will appear. Rxs under the Pre-Selected tab are 5.
selected by default; Rxs on the other tabs are not. Proceed through each tab and check the 
Rxs you want included in the report. When you are finished, click OK. 

 

 The Medication Review Report form will appear. Select the appropriate print options and 6.
click Print. The report will generate.  

 Complete the Medication Review on the form. Sign the report and have the patient do the 7.
same. 
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Scanning Medication Review Reports 

 From the Alt-X Start screen, go to Utilities > Printed Document Scan/Import.  8.

 

 The Import Scanned Documents screen will appear. Place the report pages face down on 9.
the scanner hopper. Check Scan both sides of paper if you are scanning pages with 
information on both sides and your scanner supports dual side scanning. Click Start 
Scanning. 
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 When scanning is complete, the screen will indicate how many pages were scanned 10.
successfully and how many will need to be manually reconciled. When you are finished, 
click Process and Reconcile. 

 

 The Document Scan Reconciliation screen will appear. Items ready to be processed will 11.
appear in the Documents to be created section. Items that need to be reconciled will 
appear in the Unprocessed Images section. 
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 If all Rxs were scanned successfully and appear in the Documents to be created section, 12.
click the Process Pending Documents button. Click Cancel to close the screen. 

Billing a Medication Review 

 Once scanning is complete, the Fee For Service claim will automatically populate in the F12 13.
screen. If necessary, perform a doctor search to locate the pharmacist to use as the 
prescriber and ensure all of the other information entered on the F12 screen is correct. 

 Click F12 - Fill Rx. The claim will be transmitted to the appropriate party for payment.  14.

Completing Medication Review ‘Saved for Later’ 

 To call up Medication Reviews ‘Saved for Later’, do one of the following: 1.

Patient Card 

a) Bring up the patient card using the F3 Patient search and select Medication 
Review/Dialogs from the right navigation pane.  

b) The Medication Reviews queue will appear. Select the Medication Review record you want 
to complete and click F - Call Up. 

 

F9 - Workflow 

a) Select F9 - Workflow from the Alt-X Start screen and select Medication Reviews from the 
right navigation pane. 

b) The Medication Review queue will appear. Select the Medication Review you want to 
complete and click F - Call Up. 

 

 Complete steps 4-14 of the Creating a Paper Medication Review section. 2.



 Medication Reviews – New Brunswick 
 

 

30 
 

Sample Paper Medication Review Report 

 

Viewing a Completed Medication Review 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogs from the right navigation pane.  2.

 Highlight the completed Medication Review and click F2 - View Details. 3.
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 The NB PharmaCheck Medication Check-up screen will display the scanned image of the 4.
completed Medication Review. Scanned Medication Reviews are also viewable from Patient 
Documents. 

 

Declined and Refused Medication Reviews  

This section explains the process for recording Medication Reviews that have been declined by 
the pharmacist or refused by the patient. 

NOTE: The medication review records that are declined by the pharmacist or patient refused 
can also be noted from the Medication Review queue on the F9-Workflow screen. 

Pharmacist Declined 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogs from the right navigation pane.  2.
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 Select the appropriate Medication Review and click D – Pharmacist Declined. 3.

 

 Select the appropriate option from the Decline/Refuse prompt. 4.

 

 If you select Do not prompt until the next time the patient comes in, no further action 
is required until the next time the patient visits the pharmacy. 

 If you select Do not prompt until… you will be prompted to specify the next time you 
want to be prompted for the patient’s Medication Review. Complete the form and click 
OK. 

 If you select Never Prompt for this patient you will not receive any additional 
Medication Review prompts for the patient. 

Patient Refused 

 Bring up the patient card using the F3 Patient search. 1.

 Select Medication Review/Dialogs from the right navigation pane.  2.
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 Select the appropriate Medication Review and click R – Patient Refused. 3.

 

 Select the appropriate option from the Decline/Refuse prompt. 4.

 

 If you select Do not prompt until the next time the patient comes in you will be 
prompted to specify if the review was declined by the Patient or Someone Else.  

o If you select Someone Else, the Medication Review/Dialog Refusal form will 
appear. Click the lookup button next to the Select agent field to search for the 
patient who refused the review. Select a relationship from the Relationship to 
patient menu and click OK. 

 

o No further action is required until the next time the patient visits the pharmacy. 

 If you select Do not prompt until… you will be prompted to specify the next time you 
want to be prompted for the patient’s Medication Review. Complete the form and click 
OK. 
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 If you select Never Prompt for this patient you will not receive any additional 
Medication Review prompts for the patient. 

NOTE: Medication Review records that have been declined or refused cannot be deleted 
from the Medication Reviews queue.  

Medication Review Statuses 

This section explains the statuses that appear in the Medication Review queue at various 
stages throughout the Medication Review process. 

Statuses 

 

Pending 
Reviews that have been initiated but have not yet been completed. 
 
Printed Paper 
Reviews that have been printed but have not yet been billed. 

Completed 
Reviews that have been printed and billed. 

Declined by Pharmacist  
Reviews that have been declined by the pharmacist. 

Refused by Patient  
Reviews that have been refused by the patient. 
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Fee Statuses 

 

Review Not Completed Yet  
Reviews that have been initiated but have not yet been completed. 
 
No Fee Applicable  
Reviews with no associated fees (usually declined or refused reviews). 
 
Pending Claim  
Electronic reviews: Completed reviews with a Status of Completed. 
Paper reviews: Reviews that have been printed and the option Require Document scan to 
complete Paper Med Review is off, and reports that have been printed and scanned back into 
the system if this option is enabled. 
 


