Vendor Configuration, Ordering and Receiving
Table of Contents

Vendor Configuration, Ordering, and Receiving ................................................................. 3
  Vendor Configuration ........................................................................................................ 3
  Catalog Tab ....................................................................................................................... 5
  Ordering Tab ..................................................................................................................... 8
  Receiving Tab .................................................................................................................. 9
  General Tab ..................................................................................................................... 11
  Preventing OTC Inventory Adjustments ......................................................................... 12
  Running the Drug Update Utility: .................................................................................. 13
  Reactivating Inventory Adjustments ............................................................................... 16
  Generating an Order ....................................................................................................... 17
  Automatic Order (Perpetual Inventory) ........................................................................... 18
  Manual Order .................................................................................................................. 19
    Method 1: Ordering from the Drug Order Form ............................................................ 19
    Method 2: Ordering from the Drug Card ....................................................................... 21
  Drug Order Form Options .............................................................................................. 23
  Placing an Order ............................................................................................................. 25
  Communicating with a Vendor ....................................................................................... 27
    Options Section of the Communication Screen .......................................................... 29
    Activities Section of the Communication Screen ......................................................... 30
  Sending POs .................................................................................................................... 32
    Creating Order Files to be Sent ................................................................................... 33
    Sending Order File(s) ................................................................................................. 36
  Sending an Order with a Special Handling Item ............................................................. 37
    Resending an Order ..................................................................................................... 38
  Updating Catalog Files ................................................................................................... 39
    Checking for Catalog Files .......................................................................................... 40
    Incremental Catalog Files ............................................................................................ 41
    Full Catalog Files ........................................................................................................ 41
  Downloading Catalog Files ............................................................................................. 41
  Importing Catalog Files .................................................................................................. 42
  Receiving Invoice Files .................................................................................................. 43
  Checking for Invoice Files .............................................................................................. 44
  Retrieving Invoice Files ................................................................................................ 45
Vendor Configuration, Ordering, and Receiving

The following document provides information on the requirements and set-up of File Transfer Protocol (FTP) vendor ordering and receiving. Detailed instructions are given on how to configure your system for vendor communication, how to upload drug orders, and how to download invoices into your system.

Vendor Configuration

This section outlines the configuration settings required to setup File Transfer Protocol (FTP) ordering and receiving in Kroll.

1. From the main screen, go to Utilities > Drug Ordering > Edit Vendor List. The Vendor List Form will appear.

2. Click Ins to add a new vendor entry. Select the vendor from the Type dropdown menu and click OK.
3. Ensure the **Active** checkbox is checked. This will ensure the vendor record is active and orders for that vendor can be generated and received.

- **Name**: Enter the name of the vendor.
- **Description**: Enter the vendor description.
- **Phone**: Enter the vendor’s phone number.
- **Fax**: Enter the vendor’s fax number.
- **Customer #**: Enter your pharmacy’s unique vendor account number (provided by the vendor).
- **Alternate Customer #**: Enter an alternate customer number (if available).
Catalog Tab

This section describes the contents of the **Catalog** tab on the **Vendor Information** screen.

![Vendor Information Screen](image)

**NOTE:** The fields on this screen are determined by the values entered in the **User Cost 0 Label**, **User Cost 1 Label**, etc. fields in **File > Configuration > Store > Drug**. These values are also reflected on the **Drug card, General tab**.

**Configuration > Store > Drug tab:**

**Drug Card > General tab:**

- **Update Purchase Cost:** This configuration determines if and when the **Purchase** field on the Drug card gets updated during a [Vendor] catalog load
  - **Never:** The purchase price is never updated during a catalog load.
  - **Always:** The purchase price is always updated during catalog load, even for non-default vendors.
  - **Only if Default Vendor:** The purchase price is updated during a catalog load only if the vendor is set as the **Default Vendor** on the Drug card.
Include Drug Packs with Positive On Hand Qty: When this option is unchecked, loading a catalog will only update the purchase price for drugs with a negative (-) or zero (0) on-hand quantity. The purchase price for drugs with a positive (+) on-hand quantity will not be updated during a catalog load; they will have prices updated through electronic invoice receiving or manual user manipulation.

When this option is checked, loading a catalog will update the purchase price for drugs with a negative (-), positive (+), and with zero (0) on-hand quantity. Note that the catalog price will override whatever is currently listed in the Purchase Price field on the Drug card.

**NOTE:** This option has no function when the Update Purchase Cost is set to ‘Never’.

Update User Cost 0: This option determines if and when the Update User Cost 0 field on a Drug card gets updated during a [Vendor] catalog load.

- **Never:** The Update User Cost 0 field is never updated during a catalog load.
- **Always:** The Update User Cost 0 field is always updated during a catalog load, even for non-default vendors.
- **Only if Default Vendor:** The Update User Cost 0 field is updated during a catalog load only if the vendor is set as the Default Vendor on the Drug card.

Update User Cost 1: This option determines if and when the User Cost 1 field on the Drug card gets updated during a [Vendor] catalog load.

- **Never:** The Update User Cost 1 field is never updated during a catalog load.
- **Always:** The Update User Cost 1 field is always updated during a catalog load, even for non-default vendors.
- **Only if Default Vendor:** The Update User Cost 1 field is updated via a catalog load only if the vendor is set as the Default Vendor on the Drug card.

Last Catalog Date: This is a read-only field that displays the last time a catalog was uploaded into the Kroll system.

Drug Pack Tier Mapping: This option is only applicable to Ontario pharmacies. The options in this dropdown menu Default Regular Tier and Default ODB Tier.

Update Default Drug Pack UPC: This configuration determines if and when the default UPC field on the Drug card gets updated during a catalog load.
■ **Never**: The **UPC** field is never updated during a catalog load.

■ **Always**: The **UPC** field will get updated every time a catalog is loaded.

■ **Only if Blank**: The **UPC** field will only be updated during a catalog upload when the field is blank; otherwise the existing entry in the **UPC** field will remain unchanged.

■ **Only if Default Vendor**: The **UPC** field will only be updated during a catalog load only if only if the vendor is set as the **Default Vendor** on the Drug card.

■ **Add New Drug Pack UPCs**: This configuration determines if and when a new UPC that exist in the catalog but not in the Drug card gets added. **Note** that even when a new UPC is added as a result of this configuration, it will not be set as the default UPC; rather, it will be added as a supplementary UPC in the **UPC** tab on the Drug card.

■ **Never**: New drug pack UPCs will never be added to the Drug card during a catalog load.

■ **Always**: New drug pack UPCs will always be added to the Drug card during a catalog load.

■ **Only if Default Vendor**: New drug pack UPCs will only be added to the Drug card during a catalog load only if the vendor is set as the **Default Vendor** on the Drug card.

■ **Try to Link Unlinked Catalog Items to Drug Packs**: When this option is checked, Kroll will attempt to link item numbers in the catalog that are not yet attached to the Drug card.

■ **Auto-Generate Item Numbers**: When this option is checked, the item number that the vendor uses to identify order items is auto-generated. This option is normally used by Direct Vendors only, and is not permitted for vendors with **Electronic Ordering** (Ordering tab) and/or **Electronic Receiving** (Receiving tab) values set to anything other than ‘None’.
Ordering Tab

This section describes the contents of the Ordering tab on the Vendor Information screen.

- **Electronic Ordering**: Select the appropriate option from the dropdown menu

- **Group POs by**: This option determines how purchase order (PO) items are grouped. The following options are available from the First and Second dropdown menus:
  - Catalog Special Handling
  - Drug Group (Ordering)
  - Drug Location
  - Drug Schedule

If you select **Drug Schedule**, for example, from the First dropdown menu, the PO items will be grouped by drug schedule, and a separate PO number will be generated for each drug schedule. If you select **Drug Group (Ordering)**, for example, from the Second dropdown menu, the items in each drug schedule PO will be subcategorized according to drug group.

- **Print Order report**: This option determines if a Print Order report is generated when placing an order.
  - **Yes**: A Purchase Order report will be sent directly to the printer once an order is placed.
  - **No**: A Purchase Order report will not be generated when an order is placed.
Prompt: The Purchase Order report options screen will appear once an order is placed. This screen allows you to configure report options prior to printing, previewing, or exiting the report.

Minimum Order Value: Enter the minimum value of drugs required to place an order with the vendor.

Receiving Tab

This section describes the contents of the Receiving tab on the Vendor Information screen.

Electronic Receiving: Select the vendor from the dropdown menu.

Update Purchase Cost: This configuration determines if and when the Purchase field on the Drug card gets updated when an electronic invoice is received.

- Never: The purchase price is never updated when an electronic invoice is received.
- Always: The purchase price is always updated when an electronic invoice is received, even for non-default vendors.
- Only if Default Vendor: The purchase price is updated when an electronic invoice is received, only if the vendor is set as the Default Vendor on the Drug card.

NOTE: Only items listed in the invoice will have their cost fields updated.
- **Update User Cost 0**: This option determines if and when the **Update User Cost 0** field on a Drug card gets updated when an electronic invoice is received.
  - **Never**: The **Update User Cost 0** field is never updated during a catalog load.
  - **Always**: The **Update User Cost 0** field is always updated during a catalog load, even for non-default vendors.
  - **Only if Default Vendor**: The **Update User Cost 0** field is updated during a catalog load only if the vendor is set as the **Default Vendor** on the Drug card.

- **Update User Cost 1**: This option determines if and when the **User Cost 1** field on the Drug card gets updated when an electronic invoice is received.
  - **Never**: The **User Cost 1** field is never updated when an electronic invoice is received.
  - **Always**: The **User Cost 1** field is always updated when an electronic invoice is received.
  - **Only if Default Vendor**: The **User Cost 1** field is updated when an electronic invoice is received only if the vendor is set as the **Default Vendor** on the Drug card.

- **Print Receive report**: This option determines if a Print Receive report is generated when an electronic invoice is received.
  - **Yes**: The report will be sent directly to the printer once the **Processing Invoice File(s)** task is complete.
  - **No**: The report will not be printed after the **Processing Invoice File(s)** task is complete.
  - **Prompt**: The **Receiving Order Report** options screen will appear once the **Processing Invoice File(s)** task is complete. This screen allows you to configure report options prior to printing, previewing, or exiting the report.

- **Default Action when PO not found**: This option lets you set the default action when there is no PO found in Kroll that matches the PO coming in on the Vendor invoice file. This occurs when an order is sent to the vendor outside of the Kroll application.
  - **Treat as no stock received**: Inventory and prices for products in the invoice will not get updated in Kroll. The invoice will be marked as **Received**.
  - **Treat like no-PO received**: Inventory and prices for products in the invoice will get updated in Kroll even when there is no matching PO in the Kroll system. The invoice will be marked as **Received**.
■ **Skip PO**: Inventory and prices for products in the invoice will not get updated in Kroll. The invoice will be marked as **Outstanding** so it can be received later.

**General Tab**

This section describes the contents of the **General** tab on the **Vendor Information** screen.

![General Tab Screenshot]

■ **Remote Type**: This option lets you select the method by which orders are placed to the vendor. Most stores will use the option **FTP** (File Transfer Protocol).

**NOTE**: If you wish to change the **Remote Type** value you must contact the vendor so that they can make the same configuration change on their end. If the store and the vendor have mismatched **Remote Type** values, orders will not be successfully sent or received.

■ **Remote**: This section determines what login credentials are needed when placing an order to a vendor, if applicable.

  ■ **Server**: Enter the FTP server name of the vendor or IP address.

  ■ **User**: Enter the user name that has been assigned by the vendor.

  ■ **Password**: Enter the password that has been assigned by the vendor.

■ **Local Working Directory**: This field displays the path where the vendor files are temporarily stored.

■ **Remote Path**: This field displays the path where the vendor order(s), catalog(s), and invoice(s) are stored. The remote path locations are defined by the vendor.
Preventing OTC Inventory Adjustments

Many pharmacies order OTC (over-the-counter) products separately from Rx (prescription) products. However, sometimes the invoice contains both OTC and Rx items. There are two ways to prevent your store from receiving OTC inventory and prices into Kroll when ordering both OTC and Rx items.

The first method of preventing OTC items from being received into Kroll is to run the Drug Update Utility to disable inventory adjustments for all Schedule 2 and/or Schedule 3 items. You will have to perform a drug search for the OTC items that you keep inventory for and manually activate the No Inventory Adjustment flag. You may want to use this method if you receive invoices that combine inventory and non-inventory items (e.g., when Rx items are mixed with OTC items in an invoice).

Drug Card > Ordering Tab:

The second method of preventing OTC items from being received into Kroll is to select Treat as no stock Received from the Default Action when PO not found dropdown menu found in Utilities > Drug Ordering > Edit Vendor List > [Vendor Name] > Receiving tab.

When this configuration is set, OTC items ordered outside of the Kroll application will NOT have any inventory and prices updated during invoice receiving because there is no corresponding PO found in the system. Only catalog prices will be updated if necessary.
**NOTE**: If you order OTC and Rx items outside of the Kroll application, inventory and prices will not be updated for the Rx items as well and this may be problematic if you are keeping perpetual inventory for Rx drugs.

**Running the Drug Update Utility:**


2. Click the F2 button that appears next to the Schedule field under Search Drugs for tab.

**NOTE**: All other fields should be set to ALL.
1. From the **Select Schedule** form, highlight 2 (Schedule 2 [E,D,B]) from the **Available** list and click **Insert**. The item will appear in the **Selected** list. Do the same for 3 (Schedule 3 [C]) if necessary.

2. Once all the applicable schedules have been selected to the right hand side, click **OK** or press **Enter** on the keyboard to return back to the **Drug Update Utility** screen.

3. Select the Search Drug Packs for tab and ensure Less than Zero, Equal to Zero, and Greater than Zero are checked.
4. Select the **Update Drug Packs** tab and ensure **Inventory Adj.** is checked. Select **Disable Inventory Adjustment** from the dropdown menu.
5. Click Run to inactivate inventory adjustments for the drug schedules selected in Schedule 2 and Schedule 3 (as mentioned above in step 3).

![Image of Drug Update Utility]

Reactivating Inventory Adjustments

1. Perform a drug search from the Drug card and locate the drug for which you want to reactivate inventory adjustments.

2. Select the drug record and click Edit.
3. Select the **Ordering** tab on the Drug card and uncheck the **No Inventory Adjustment** option.

4. Click **Save** or press **Enter** on the keyboard from the F5-Drug Card to save changes.

### Generating an Order

This section outlines the process for generating orders and electronically sending them to a vendor.

1. Go to **Utilities > Drug Ordering > Generate Order**.

2. A prompt will appearing asking if you want to generate an **Automatic** or **Manual** order. Select **Automatic** to generate an order based on the **Min/Max** or **Days Supply** values in the Drug card; select **Manual** to generate an order from the wholesaler catalog.
NOTE: A percentage field is available for instances where you want to inflate the quantity of drugs being ordered for all items in the order. For example, ‘Increase Min/Max re-order levels by 10% (For this order only)’ would cause the order quantity to increase by 10% for all items in the order.

Automatic Order (Perpetual Inventory)

Automatic ordering can only be performed when the option Enable Automatic Drug Ordering is enabled in File > Configuration > Store > Order.

If you select Min/Max from the Base ordering on dropdown menu, automatic ordering will occur when the Min/Max values on the Drug card are below minimum.

If you select Days Supply from the Base ordering on dropdown menu, automatic ordering will occur when the Days value on the Drug card is below minimum. This value is determined by the average sales levels of the drug.
If **Automatic** ordering is selected, the system will check all drugs with automatic ordering enabled and generate a suggested order similar to the one below:

![Drug Order Form](image)

**NOTE:** Drugs that have an On Hand value lower than the Minimum will be placed on order given that the drug has automatic ordering enabled. The minimum value is either entered manually by you or calculated based on the days' supply (i.e., usage).

**Manual Order**

If **Manual** ordering is selected, you can choose specific items from the catalog to be placed on order instead of having the system auto-generate a suggested order based on min/max and on-hand values.

**Method 1: Ordering from the Drug Order Form**

1. Click **Add Item** to access the wholesaler catalog.
The **Insert Order Item** screen will appear. You can search for items from this screen using the following criteria:

- Description
- Drug Identification Number (DIN)
- Item Number
- Pack Size
- UPC

**NOTE**: The method used to search for drugs in the wholesaler catalog is differing from the method used to search for drugs in Kroll. For example, if you are searching for Altace 10mg, typing ‘Altace, 10’ in the description field will yield ‘no items found’.

1. Highlight the drug and click **Select** to add the drug to the order.

2. Enter the quantity you want ordered and click **OK**.
Method 2: Ordering from the Drug Card

1. Bring up the drug you want to order in the Drug card. Access the **Ordering** tab and click **Ins** in the **Available Vendor Items** section.

2. Select the appropriate vendor from the **Vendor** dropdown menu.

3. Enter the item number in the **Item Number** field and click **Save**. Or, click **Select From Catalog** to select the drug from the catalog.
a) If you chose **Select From Catalog**, highlight the drug from the **Catalog Items** list and click **Select**.

4. The item will be added to the **Available Vendor Items** list on the Drug card.
Drug Order Form Options

The Drug Order Form contains a list of items placed on order, regardless of whether the order is generated automatically or manually. The following options are available from the Drug Order Form.

- **Add Item**: Selecting this option will pull up the Insert Order Item form which allows you to manually add products to the order by searching the wholesaler catalog.

- **Edit Order Quantity**: Highlighting an order item and selecting this option allows you to edit the quantity being ordered, along with other drug parameters such as On Hand, Min On Hand, Max On Hand, No Inv Adjustment, and Disable Auto Order.

- **Delete Item**: Highlighting an item and selecting this option allows you to remove the item from the order. Note that the item will appear again on the next automatically generated order.

- **Move Selected Items**: Highlighting an item and selecting this option allows you to move the item from one wholesaler to another. Note that the default vendor on the Drug card remains unchanged so “moving a selected item” will apply to the current order only.
- **Preview**: Selecting this option allows you to print or preview the order before it is sent.

- **Place Order**: Selecting this option will call up the **Create Purchase Order** form and begin the process of sending an order to the wholesaler.
Placing an Order

This section outlines the process for placing orders and electronically sending them to a vendor. Once you have finished editing, deleting and/or adding items to the drug order, the order can be sent to the wholesaler as follows:

1. Click on Place Order from the Drug Order Form to call up the Create Purchase Order screen.

2. A purchase order (PO) number will automatically be assigned to the order if you enabled Auto Increment PO Numbers in File > Configuration > Store > Order. If this option is not enabled, enter a PO number in the PO Number field. Click OK or press Enter to proceed.
If the vendor considers one or more items in your order to be a narcotic, enter the vendor-specific narcotic code in the **Narcotic Code** field.

**NOTE:** Click **View Vendor** to view the vendor settings. Details listed on this screen are for information purposes only and cannot be edited.

1. Click **Create** or press **Enter** on the keyboard to generate the order so that it can be sent electronically to the Vendor.

2. Answer **Yes** when asked ‘**Do you want to send the electronic order now?**’

**NOTE:** Answering **No** will place the order into **Pending Orders** so that it can be sent at a later stage from **Utilities > Drug Ordering > Communication with > [Vendor Name]**.

1. Click **Start** or press **Enter** from **Drug Ordering > Communication with > [Vendor name]**. This will begin the process of sending the PO to the vendor.
1. As the purchase order is being sent to the vendor, the Activities portion of the screen will begin to populate with the status of actions being taken.

![Diagram showing activities being populated]

2. When the order has been transmitted successfully, click Finish or press Enter to close the communication screen.

**Communicating with a Vendor**

This section outlines the process of communicating with a vendor after placing an order. Communicating with the vendor means establishing a connection between Kroll and the vendor’s server for the purpose of exchanging information.

It is important to note that only one connection to the vendor’s server can be established per customer account. Therefore, if the vendor communication screen is open on a terminal (or on a terminal at another store in the case of shared database), you will receive a message similar to the following until communication on that terminal has ended:

![Information Message]

The vendor communication screen follows the standard Kroll application size of 800 x 600, but can be maximized or resized to take advantage of large monitors and/or high resolution screens.
The communication screen contains two sections: **Options** (top), and **Activities** (bottom). The **Options** section lets you decide which process or processes are executed when the communication is initiated. The **Activities** section is an information panel that shows all activities performed after the start of communication.
The Options and Activities sections can be resized by dragging the section divider up and down, as shown:

Options Section of the Communication Screen
The Kroll application automatically decides which communication options to initiate, depending on how you access the vendor communication screen.

1. If you access the vendor communication screen through Utilities > Drug Ordering > Communicate with > [Vendor name], then:
   - Send PO(s) option is OFF
   - Download Catalog File(s) option is ON (This option is always ON when accessing through this method to ensure that the latest catalog is uploaded into Kroll)
   - Retrieve Invoice File(s) option is ON
2. If you access the vendor communication screen by answering **Yes** to the ‘Do you want to send the electronic order now?’ prompt, then:

- **Send PO(s)** option is **ON**
- **Download Catalog File(s)** option is **OFF**
- **Retrieve Invoice File(s)** option is **OFF**

**NOTE:** You can manually change which process will be initiated by turning ON or OFF any of these options whenever they are shown. Note that turning ‘Send PO(s)’ OFF will disabled the top grid, and turning ‘Retrieve Invoices File(s)’ off will disabled the ‘Print Receiving Order Report’ option.

**Activities Section of the Communication Screen**

The Activities panel displays all activities performed during the communication. It will include the following information:

- The activity being executed at each moment of communication
- The status of each activity (i.e. Completed, Skipped, or Cancelled)
- Extra information related to each activity
- The termination of communication with the vendor (End of Activities)
Once the communication process begins, the **Options** section will disappear and the **Activities** panel will expand to fill the whole screen.

Vendor communication consists of three processes:

- Sending PO(s)
- Downloading Catalog File(s)
- Retrieving Invoice File(s)

These processes are independent of each other and can be turned ON or OFF each time communication with a vendor is initiated.
Sending POs

This section explains the process of electronically communicating with a vendor by sending POs (purchase orders).

Once the **Send PO(s)** option is checked, you can send or re-send orders to the vendor’s server. The following screen shows pending orders (**Outstanding**) in the system. Pending orders are orders that were generated but NOT transmitted to the vendor’s server.

<table>
<thead>
<tr>
<th>Status</th>
<th>Date</th>
<th>Purchase Order</th>
<th>Items</th>
<th>Total Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pending</td>
<td>23-Feb-2011</td>
<td>2639</td>
<td>4</td>
<td>$1894.45</td>
</tr>
<tr>
<td>Pending</td>
<td>22-Feb-2011</td>
<td>2638</td>
<td>3</td>
<td>$518.93</td>
</tr>
<tr>
<td>Pending</td>
<td>18-Feb-2011</td>
<td>2633</td>
<td>3</td>
<td>$275.34</td>
</tr>
<tr>
<td>Pending</td>
<td>16-Feb-2011</td>
<td>2632</td>
<td>1</td>
<td>$252.65</td>
</tr>
</tbody>
</table>

The **All POs** option will show purchase orders that are **Pending** and **Ordered**. When this option is selected you can access the **Date Range** and **Status** controls, which filter orders to the specified parameters. Note that orders with a status of **Received** or **Cancelled** are not shown in this list, regardless of the date range or status specified.

- **Date Range**: This option lets you select a date ranging based on the date the PO was generated.

- **Status**: Select one of the following options from this dropdown menu:
  - **Order Pending**: Shows outstanding orders (orders that were not transmitted to the vendor’s server).
  - **Ordered**: Shows orders that have been transmitted to the vendor’s server.
  - **All**: Shows both **Ordered** and **Pending** orders.
Regardless of whether the grid is showing Outstanding or All POs, if there are no orders for the specified parameters, the grid will show 'No Purchase Orders Found'.

When there are POs in the grid, you can sort the POs by clicking the column headings. For example, clicking the Total Price column-title sorts the list by ascending price; clicking again will sort by descending price. Two or more order files can be sent at the same time.

Creating Order Files to be Sent

Once you have logged into the vendor’s server the communication process will create the electronic file(s) to be sent, and the file(s) will be created according to the layout determined by the vendor. The file(s) will be saved in the designated vendor directory specified in the Local Working Directory field in the General tab on the Vendor Information screen.
The files will be temporarily stored there until they are picked up for transmission.

1. Click the Start button on the vendor communication screen to initiate the communication.

   In the screen below, the activity Logging into FTP Server is completed and the Creating Order Files to be sent activity is beginning.

   ![Screenshot of vendor communication screen]

   Note the two progress bars located at the bottom of the screen; the top progress bar indicates what percentage of all files have been created; in this case the progress is at 67% because two of the three files has been created. The bottom progress bar indicates the creation progress of each file; in this case the progress is at 0% because the system has not yet begun creating the third file.

   The order file will be created in the designated vendor directory. Each vendor uses a unique file naming convention.

   When all files have been created, the Creating Order Files to be sent activity will show a status of Completed and the number of files that were created will be displayed. Note that the Sending Order File(s) activity is now in progress.
If the Send POs option is NOT checked, the information panel will show that the Creating Order Files to be sent activity was **Skipped**, since you did not choose to send anything. The Sending Order File(s) activity will be skipped as well since no files were created for transmission to the vendor’s server.

![Image of Vendor Configuration, Ordering, and Receiving](image)

If the Send POs option is checked, but there are no outstanding POs selected, a prompt will appear asking if you want to continue:

![Image of Vendor Configuration, Ordering, and Receiving](image)
If you answer Yes, the information panel will show that the Creating Order Files to be sent activity was skipped since you did not choose to send the PO. Again, the Sending Order File(s) activity will be skipped since no files were created for transmission to the vendor’s server.

Sending Order File(s)

Once the order files have been generated, the Sending Order File(s) task will begin automatically, which transmits the order files to the vendor’s sever. This process will pick up the saved files from the designated vendor directory and send them to the vendor’s server. Similar to the order creation process, you can follow the progress of Sending Order File(s) from the information panel.

1. As soon as each file is successfully transmitted, they will be removed from the directory.
2. Once all files have been transmitted, the information panel will show the number of files that were transmitted with a status of Completed.

Sending an Order with a Special Handling Item

There may be instances where a vendor requires that a **Pharmacist License Number** be submitted every time an order containing a special handling item is sent to their server. In order to perform this action, follow the steps mentioned below:

During order transmission, if you have logged into Kroll as a technician, you must be associated with a pharmacist to send the narcotic order. If you are not associated with a pharmacist, the transmission process will stop and the following warning message will appear:

Click **OK** or press **Enter** on your keyboard. The **Pharmacist Association Form** will appear.
Have a pharmacist enter his or her initials in the **Pharmacist Initials** field. The corresponding **Technician** will be displayed at the bottom of the screen. Click the **Associate** button to associate the Technician to the Pharmacist.

![Pharmacist Association Form]

**Resending an Order**

This option is used in instances where the file did not transmit to the vendor and needs to be resent.

1. Go to **Utilities > Drug Ordering > Communicate with > [Vendor name]**.

2. Place a checkmark next to **Send PO(s)**. Click **All POs** and place a checkmark next to the PO(s) that need to be resent.

3. Click **Start** or press **Enter** on the keyboard to resend the PO(s).
4. Answer Yes to the prompt 'There are POs selected to be sent that are marked as already being sent. Do you want to resent it anyway?'.

Updating Catalog Files

This section outlines the process for updating catalog files. When you perform this task, you instruct the system to download one or more catalog files posted on the vendor’s server.

There process to download catalog files consists of three tasks:

- Checking for catalog files
- Downloading catalog files
- Importing catalog files

Checking for catalog files and downloading catalog files are performed in sequence. Importing catalog files is executed after logging out of the vendor’s server.
Checking for Catalog Files

This task involves checking all available catalog files on the vendor's server and determining if there are any new files that need to be imported into Kroll.

To see the last time a full or incremental catalog file was loaded into Kroll, go to Utilities > Drug Ordering > Edit Vendor List and double-click the vendor name. The system will reference the date listed in the Last Catalog Date field to determine if there are catalog files that require downloading and, if so, which ones; only new files will be considered.

When all of the tasks described in the Sending POs section are complete, the system will begin checking for catalog files.
When checking is complete the informational panel will show many files were found. The next task, **Downloading Catalog File(s)**, will already be in progress.

If no catalog files were found, the **Downloading Catalog File(s)** task will be skipped, as there are no files to download. Later, the **Importing Catalog File(s)** task will also be skipped.

There are two types of catalog files:

- Incremental catalog files
- Full catalog files

Each vendor has a unique catalog naming convention.

**Incremental Catalog Files**

Incremental catalog files are typically small files that contain information that has been changed or added from the last catalog. These files only update existing items and/or insert new ones into Kroll. Items that are in the current catalog database, but are not in the full catalog file will **not** be marked as "deleted" during an incremental catalog load.

Kroll will check the store’s province to retrieve proper catalog files.

**Full Catalog Files**

Full catalog files replace the catalog that was previously loaded into Kroll. A majority of the items in full catalog files will already exist in the current catalog database; for these items, prices and other information will be updated as required. Items in full catalog files that do not exist in the current catalog database will be added. Lastly, items that were in the current catalog database, but are not in the full catalog file will **be considered “deleted” and you will not be able to add that item to future orders.**

**Downloading Catalog Files**

After **Checking for Catalog Files**, the **Downloading Catalog File(s)** task will begin. As soon as each file is downloaded, the information panel will show the corresponding filename. You can look at the two progress bars at the bottom of the screen to determine the progress of the download. The top progress bar shows what
percentage of all catalogs have been downloaded and the bottom progress bar shows what percentage of each catalog has been downloaded.

The catalog files will be downloaded in the designated vendor folder where they will sit until they are imported into Kroll. Once all catalog files are downloaded, the information panel will show a status of **Completed**.

**Importing Catalog Files**

If incremental catalog files were found and downloaded from the vendor’s server, they must be imported into Kroll. The **Importing Catalog Files** task is automatically performed after logging out of the vendor’s server. This task will update new catalog information into the Kroll database.
The **Load Catalog** screen will appear. No intervention is required here; the information panel simply displays the progress of the catalog import.

When all files have been imported into the database, the information panel will show a status of **Completed**.

Receiving Invoice Files

This section outlines the process for receiving invoice files. When a pharmacy physically receives a drug order from the wholesaler, the order must be received into the Kroll system to update the **On Hand** values and **Pricing**. Once the **Retrieve Invoice File(s)** option is checked, you will be able to retrieve one or more invoice files posted on the vendor’s server. The content of the invoices (e.g., shipped quantity, pricing) is determined by the vendor.

The process of retrieving invoice files consists of three tasks:

- Checking for invoice files
- Retrieving invoice files
- Processing invoice files
Checking for Invoice File(s) and Retrieving Invoice File(s) are done in sequence. The Processing Invoice File(s) task is executed after logging out of the vendor’s server.

Checking for Invoice Files

Each vendor has a unique invoice file naming convention.

Similar with other tasks, the information panel will show when the Checking for Invoice File(s) task is in progress.

When the Checking for Invoice File(s) task is complete, the information panel will show a status of Completed, along with the number of invoice files that were found.

If no files were found, the Retrieving Invoice File(s) task will be skipped since there are no files to retrieve. Later, the Processing Invoice File(s) task will be skipped as well.
Retrieving Invoice Files

If invoice files were found during the Checking for Invoice Files task, the Retrieve Invoice File(s) activity will automatically initiate. As soon as each file is retrieved, the information panel will show the corresponding filename. You can follow the progress of each file being retrieved on the top progress bar; the bottom progress bar tracks what percentage of all invoices has been retrieved.

The invoice files will be temporarily saved in the designated vendor directory. The invoices will be saved in this folder until they are updated into the Kroll system.

If an invoice file was retrieved from the vendor’s server, but was not processed because you cancelled it, it will be picked up in the next communication process.
Processing Invoice Files

If invoice files were found and retrieved, the Processing Invoice File(s) activity will be automatically initiated. At this point, the communication process will try to match information in the invoice file to a purchase order in Kroll. When the process finds a match between an invoice file and a Kroll PO, you will see a screen similar to the one below:

The above screen contains a top panel and a bottom panel. The top panel shows a list of retrieved invoice files with associated PO numbers. As well, an information message is shown to the left of the PO number; this message will help you decide which file to process.

There is a checkbox on the upper left hand side of the screen that helps you select or deselect all invoice files/POs in the list. As well, there is an indicator on the upper right hand side that indicates x of y PO(s) have been selected.
The bottom panel shows a left and right grid; the information displayed is related to one of the invoice files shown in the top panel. The left grid shows the information contained in the invoice file. The right grid shows all the items within a PO in Kroll. You can resize the panels to show more or less information.

In the above screen, the invoice file on the left (i0002559) is associated with PO 2559 on the right. The invoice file contains only four items. The idea is to allow you to see information inside the invoice file compared to information in the PO before the file is processed. Clicking on any item on either side of the grid will highlight the corresponding item on the opposite side if available.

Looking at the right-hand grid above, item 00148619 (NOVO-TRIMEL 40MG/5ML SUSP), which is highlighted in red, was ordered for one pack (Ord Qty column). Comparing with the left grid, we can see that the received quantity (Rcv Qty column) is also one pack, which means everything ordered was received.
Looking at the right-hand grid below, item 00407627 (PMS-FLUOROMETHOLONE 0.1%), which is highlighted in aqua, was ordered for four packs, but the invoice file indicates that the vendor only sent three packs. Take note of the floating yellow message that reads “Short-Partial quantity shipped”.

Looking at the right-hand grid below, item 000481124 (APO-PROPRANOLOL 20MG), which is highlighted in aqua, is out of stock and nothing was shipped, although the left-hand grid indicates that one pack was ordered. Take note of the floating yellow message that reads “[Vendor name] Short (No Stock)”. 

Vendor Configuration, Ordering, and Receiving
On the right-hand grid below, item 02170538 (PMS-CLARITHROMYCIN 500MG TABS) was ordered, but the invoice file on the left indicates that the vendor sent item 02170530 as a substitution. Take note of the floating yellow box that reads “Substitute for 02170538 – substitution”. The vendor will only send substitutions for customers that provide consent to do so.

When the Processing Invoice File(s) task does not find a matching PO in Kroll, you must decide what to do with the invoice. You will see a screen similar to the one below.
There are three options to choose from:

- **Treat as no stock received**: This option will receive the invoice file, taking into consideration that no equivalent PO exists in Kroll; however, no on-hand quantities will be updated; only catalog prices will be updated, if necessary. This option should be used when an order was placed outside of the Kroll application for items that do not have inventory and prices monitored within Kroll (e.g., OTC items).

- **Treat like non-PO receive**: This option will receive the invoice file, taking into consideration that no equivalent PO exits in Kroll, and the process will update the on-hand quantity and prices for associated drug packs, if available. This option should be used when an order was placed outside of the Kroll application for items that have inventory and prices monitored within Kroll (e.g., Rx order sent directly from the vendor's website).

- **Skip this PO**: This option means the invoice file will not be processed and will remain outstanding.

To set a default action for this option, go to **Utilities > Drug Ordering > Edit Vendor List > [Vendor name] > Receiving** and select the appropriate option from the **Default Action when PO not found** dropdown menu.
If you do not select an invoice file/PO equivalent, the invoice will sit in **Utilities > Drug Ordering > Electronic Invoice Receiving** with no **Received** date.

Processing an invoice consists of four steps:

1. **Update Purchase Order information in Kroll**: In this step, the purchase order status will be set to “Received” or “Partially Received”. This step will not be executed when the file/PO is configured to be treated like a non-PO receive, or no stock received.

2. **Update Drug Pack Prices**: In this step, the system will look at the **Receiving** settings set in **Utilities > Drug Ordering > Edit Vendor List > [Vendor name] > Receiving** to determine if and where drug pack prices are updated. This step will not be executed when the file/PO is configured to be treated as “no stock received”.

---

**Vendor Configuration, Ordering, and Receiving**

51
3. **Adjust Drug Pack Inventory:** In this step, the on-hand quantity of a drug pack will be adjusted if the following settings are in place:

- Perform Inventory Adjustment in **File > Configuration > Store > Order** must be turned on.
- No Inventory Adjustment in the Ordering tab on the Drug card must be turned off.

This step will not be executed when the file/PO is configured to be treated as “no stock received”.

4. **Update Catalog Prices:** In this step, the system will look at the **Catalog File Loading** rules set in **Utilities > Drug Ordering > Edit Vendor List > [Vendor name]** to determine if and where drug pack prices are updated via the catalog.

When the **Processing Invoice File(s)** task is complete, the status will show as **Completed** and the information panel will show the message “### End of Activities ###”. As well, two new buttons, **Retry** and **Finish**, will appear at the bottom of the communication screen to indicate that communication has finished. Click **Finish** or press Enter on the keyboard to close the communication screen. Click **Retry** or press **CTRL+R** to start another communication with the vendor.
Receiving Order Reports

The Receiving Order Report is generated after the Processing Invoice File(s) task is complete. The report shows how many items were ordered and received, as well as the dollar amount invoiced. From the communication screen (Utilities > Drug Ordering > Communicate with > [Vendor name], there are three options for printing the report:

- **No**: The report will not be printed after the Processing Invoice File(s) task is complete.
- **Yes**: The report will be sent directly to the printer once the Processing Invoice File(s) task is complete.
- **Prompt**: The Receiving Order Report options screen will appear once the Processing Invoice File(s) task is complete. This screen allows you to configure report options prior to printing, previewing, or exiting the report.

![Image of the communication screen](image-url)
To set a default action for this option, go to **Utilities > Drug Ordering > Edit Vendor List > [Vendor name] > Receiving** and select the appropriate option from the **Print Receive report** dropdown menu.

You can also print the Receiving Order Report by going to **Utilities > Drug Ordering > Electronic Invoice Receiving**, highlighting the PO, and clicking **View/Reprint**.
Depending on the content of the invoice, the Receiving Order Report can have one section (Regular or Narcotic) as illustrated below:

![Receiving Order Report](image)

<table>
<thead>
<tr>
<th>Order</th>
<th>Qty</th>
<th>Inv.</th>
<th>Item #</th>
<th>Description</th>
<th>Form</th>
<th>Pack Size</th>
<th>Invoice Acq. Cost</th>
<th>Price Diff.</th>
<th>Total Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>900</td>
<td>MACRODANTINE TABLET</td>
<td>TAB 0221810</td>
<td>90</td>
<td>120.31</td>
<td>0.00</td>
<td>120.31</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1,320</td>
<td>CLINAMYCOBIVIOTIN</td>
<td>ML 02256930</td>
<td>60</td>
<td>15.37</td>
<td>0.00</td>
<td>15.37</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>2</td>
<td>40</td>
<td>HYDROXYMETHYLMELANIT</td>
<td>GM 02248865</td>
<td>15</td>
<td>2.20</td>
<td>0.00</td>
<td>2.20</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>2</td>
<td>66</td>
<td>LAMIKIN/LEVEMICIN</td>
<td>ML 02248865</td>
<td>3</td>
<td>35.85</td>
<td>0.00</td>
<td>35.85</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>100</td>
<td>METROGEL 0.75%</td>
<td>GM 0202832</td>
<td>60</td>
<td>43.76</td>
<td>0.00</td>
<td>43.76</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>3</td>
<td>300</td>
<td>PALACEPHAQORYTHRIPRAX</td>
<td>DOS 0221932</td>
<td>120</td>
<td>25.56</td>
<td>0.00</td>
<td>25.56</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>2,300</td>
<td>NOVACAIN SPRAY</td>
<td>ML 0224929</td>
<td>100</td>
<td>13.27</td>
<td>0.00</td>
<td>13.27</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>300</td>
<td>PREDNISONE SODIUM</td>
<td>ML 0224929</td>
<td>100</td>
<td>13.27</td>
<td>0.00</td>
<td>13.27</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1,196</td>
<td>REGULAR DEPOSITIVE SOLUTION</td>
<td>GM 0229692</td>
<td>100</td>
<td>10.24</td>
<td>0.00</td>
<td>10.24</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>3</td>
<td>45</td>
<td>XILETHONE</td>
<td>TAB 0220220</td>
<td>9</td>
<td>57.61</td>
<td>0.00</td>
<td>57.61</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>2</td>
<td>72</td>
<td>PHENOTOPHYL SUPPOST</td>
<td>SUP 0224523</td>
<td>12</td>
<td>15.56</td>
<td>0.00</td>
<td>15.56</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>300</td>
<td>SPHINX CLINICAL TREATMENT</td>
<td>TAB 0223652</td>
<td>100</td>
<td>18.64</td>
<td>0.00</td>
<td>18.64</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>240</td>
<td>VANCOMYCIN PARENTERAL TREATMENT</td>
<td>TAB 0227904</td>
<td>90</td>
<td>106.32</td>
<td>0.00</td>
<td>106.32</td>
</tr>
</tbody>
</table>

Subtotal: 763.01
Total: 763.01
Vendor Configuration, Ordering, and Receiving

Or, the report may contain two sections (Regular and Narcotic), as illustrated below:

The subsections highlighted in green in the above image categorize the items in the report as follows:

- **Items Received in Full**: Order Qty = Previously Received + Received Quantity.
- **Items Partially Received**: Order Qty > Previously Received + Received Quantity.
- **Over Received Items**: Order Qty < Previously Received + Received Quantity.
- **Items Not Received**: Received Qty = 0.
- **Non-PO Received Items**: Items ordered outside of the Kroll application.
- **No Stock Received Items**: Items that are marked as received, but on-hand quantities were not updated in the Drug cards.
- **Discontinued Items**: Discontinued by the vendor.
- **Items Cancelled by Customer**: Items that were ordered, but later cancelled by the customer.
The following columns appear in the report:

- **Order Qty**: Displays the quantity that was ordered.
- **Prev Recv’d**: Displays the quantity that was previously received by other invoices at the time the report is printed.
- **Recv’d Qty**: Displays the quantity shipped by the vendor in this invoice.

Note that an item can appear in the **Prev Recv’d** category in one Receiving Order Report, and later appear in the **Items Received in Full** category in another Receiving Order Report. The following example demonstrates this scenario:

Invoice file i0000037 with item number 02129732 (Naprelan 375mg Tabs) has a **Prev Recv’d** quantity of one, but because the **Order Qty** is three and nothing was previously received, it is treated as a partially received item. A vendor message (**Vendor Msg**) will indicate that “additional quantity from alternate warehouse” is on its way.
Later, in invoice file i000038, the vendor sends two more packs of Naprelan 375mg Tabs (item number 02129732). Since the received quantity in this invoice plus the quantity that was previously received is equal to the order quantity, the item is now considered **Received in Full**.

---

- **Invoice Acq. Cost**: The price for the item in this invoice. This price can be the same as what is currently in your system, or it may be different if prices have changed since it was last purchased.

- **Price Diff**: The difference between the price of the item in Kroll before receiving and the price of the item in this invoice.

---

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Norflex</td>
<td>$92.55</td>
<td>$92.55</td>
<td>$99.99 - $92.55 = $7.44</td>
</tr>
</tbody>
</table>

---
The acquisition cost may or may not be updated depending on the configurations set in **Electronic Ordering and Receiving**. When the price for an item is not updated, the report will display a reason:

- **Total Amount**: The value of the number of packs ordered for an item multiplied by the **Invoice Acq. Cost**.